Networked Media Tank
On-Demand network share mounting - Printable Version

+- Networked Media Tank (http://www.networkedmediatank.com)
+-- Forum: Community Jukebox, Themes, & UserApps Section (/forumdisplay.php?fid=106)
+--- Forum: 200/300/400 Series - Development and User Apps (/forumdisplay.php?fid=121)
+---- Forum: 100 Series - Development and User Apps (/forumdisplay.php?fid=33)
+---- Thread: On-Demand network share mounting (/showthread.php?tid=17494)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24


RE: On-Demand network share mounting - semprini - 03-30-2009 01:33 AM

(03-30-2009 12:12 AM)excal Wrote:  you just need to make sure you set the config file to point to the place your index is on...

Got it. Thanks!


RE: On-Demand network share mounting - PoPEye - 03-31-2009 08:23 AM

journey4712 , thank you for a great app. Just wanted to say it's working great with llink and my "iso-hack" where I replace http links to a smb/nfs share for being able to play iso files with menu. I just did a plain install with out any tweak and it works straight out of the box, sweet!!


RE: On-Demand network share mounting - Ragnar - 04-11-2009 10:15 AM

Appreciate the work, but............
after installing wrapper 0.10 my video-output went to 480i (not even a supported resolution from popcorn !)
could not get around it, so i did an uninstall
deleted the apps folder (uninstall doesn't do this ?)
This did not help, now my files wouldn't play at all (video_ts + iso)

So took the power off and booted again, everything is fine now
Guess this guy here has the same problem http://www.networkedmediatank.com/showthread.php?tid=20496&highlight=480i


RE: On-Demand network share mounting - hxall - 04-11-2009 04:12 PM

(04-11-2009 10:15 AM)Ragnar Wrote:  Appreciate the work, but............
after installing wrapper 0.10 my video-output went to 480i (not even a supported resolution from popcorn !)

I have been reporting this for a while that with 0.10 my HDTV would show "unsupported resolution," I would get audio but no video. This problem only occurred on my a-110 and not on my a-100. The difference probably has more to do with the fact that the a-110 is connected thru HDMI (1080p60) and the a-100 via component (1080i60).

Sorry you are having problems, but glad to see it's not just me...


RE: On-Demand network share mounting - journey4712 - 04-11-2009 11:09 PM

tbh i'm not really sure what could happen to cause resolution changes, and i've no clue how it might be fixed. The Mono.Wrapper program just looks at the options passed to the video player, it shouldn't be changing them(unless you pass an m3u or pls playlist). If anyone can figure out what is causing the difference i would love to know and be able to fix it, but i'm fairly stumped. I've tested with my A-100 connected via HDMI(1080p) and connected via SD(the single RCA cable) but dont see the issues repeated.

journey4712


RE: On-Demand network share mounting - dave.t - 04-12-2009 12:53 AM

Hi Journey
Just trying out your mount on demand.
Just one problem so far. I use GBPVR and I call it from an icon on the index page
Code:
<a href="http://localhost.drives:8883/HARD_DISK/mvpmc/gbpvr.cgi" id="thumbimage">

The gbpvr.cgi has the following code

Code:
#!/bin/sh

echo "Content-Length: 80";
echo "Content-type: text/html";
echo "";

cd ~
mkdir /etc/mvpmc >/dev/NULL
echo "";

if [ -f /etc/mvpmc/mvpmcx2 ]
  then
  echo "Already Connected!";
else  
   mount --bind  /opt/sybhttpd/localhost.drives/HARD_DISK/mvpmc /etc/mvpmc
   mount -t cifs //192.168.1.1/MVPMC /etc/mvpmc/ -o username=guest,rw;
   cp /etc/mvpmc/utelnetd /usr/bin;
   chmod 777 /etc/mvpmc/*;
   utelnetd -l /bin/sh -p 23 &
   ln -s /lib/librmjpeg.so /lib/libjpeg.so.62
   ln -s /lib/librmzlib.so /lib/libz.so
   ln -s /lib/librmzlib.so /lib/libz.so.1
   ln -s /lib/librmzlib.so /lib/libz.so.123
   echo "Telnetd started on port 23............";
fi

killall gaya
sh -c /etc/mvpmc/startmeup 2>/dev/null >/dev/null &

This calls the startmeup file which has the following
Code:
#echo "Shell to mvpmcx2 "

#remove the # from most appropriate line

# TV settings as setup

# 3/etc/mvpmc/mvpmcx2 &
/etc/mvpmc/mvpmcx2 -m 1080p --emulate 192.168.1.1

# Analog TV settings

#/etc/mvpmc/mvpmcx2 -m ntsc &
#/etc/mvpmc/mvpmcx2 -m pal &

# HDMI/DVI settings examples

#/etc/mvpmc/mvpmcx2 -m 720 &
#/etc/mvpmc/mvpmcx2 -m 720 --frequency 50 &

#/etc/mvpmc/mvpmcx2 -m 1080i &
#/etc/mvpmc/mvpmcx2 -m 1080i --frequency 50 &
#/etc/mvpmc/mvpmcx2 -m 1080p &

This calls mvpmcx2 which is the client for GBPVR.
Everything was working fine until I installed the on demand software.
The following error comes up on the popcorn screen after I hit the GBPVR icon

#!/mnt/syb8634/server/php5-cgi -qd register_argc_argv=1 starting mount wrapper

I hit return and it takes me back and if I hit the icon again it works.
Once in I have more hassles such as changing channels. It ends up locking things up but not all the time. Also when I hit the power button it does not go back to the index
Is there any way of using GBPVR the old way and using your play on demand for the jukebox.
Here is also the log but the changing channels worked this time.
Code:
Starting Mono.Wrapper: /bin/mono -initialize
Restoring saved mono settings
Drive is Local: HARD_DISK
Sending bootup url: http://localhost.drives:8883/HARD_DISK/?home=0

Starting Mount.Wrapper: /bin/mount --bind /opt/sybhttpd/localhost.drives/HARD_DISK/mvpmc /etc/mvpmc
Unrecognized command line options
executeMount
execute /bin/busybox mount Array
/bin/busybox mount '--bind' '/opt/sybhttpd/localhost.drives/HARD_DISK/mvpmc' '/etc/mvpmc'
Starting /bin/busybox mount '--bind' '/opt/sybhttpd/localhost.drives/HARD_DISK/mvpmc' '/etc/mvpmc'

Starting Mount.Wrapper: /bin/mount -t cifs //192.168.1.1/MVPMC /etc/mvpmc/ -o username=guest,rw
Unrecognized command line options
executeMount
execute /bin/busybox mount Array
/bin/busybox mount '-t' 'cifs' '//192.168.1.1/MVPMC' '/etc/mvpmc/' '-o' 'username=guest,rw'
Starting /bin/busybox mount '-t' 'cifs' '//192.168.1.1/MVPMC' '/etc/mvpmc/' '-o' 'username=guest,rw'

Starting Mono.Wrapper: /bin/mono -nogui http://192.168.1.1:7647/stream?f=D%3a\TvTemp\A Man For All Seasons_2_20090412_09001100.ts -dram 1 -single
execute /bin/mono.real Array
/bin/mono.real '-nogui' 'http://192.168.1.1:7647/stream?f=D%3a\TvTemp\A Man For All Seasons_2_20090412_09001100.ts' '-dram' '1' '-single'
Starting /bin/mono.real '-nogui' 'http://192.168.1.1:7647/stream?f=D%3a\TvTemp\A Man For All Seasons_2_20090412_09001100.ts' '-dram' '1' '-single'
/bin/mono.real '-nogui' 'http://192.168.1.1:7647/stream?f=D%3a\TvTemp\A Man For All Seasons_2_20090412_09001100.ts' '-dram' '1' '-single' Exited with return status of 0
Saving mono settings for incase of reboot

Starting Mono.Wrapper: /bin/mono -nogui http://192.168.1.1:7647/stream?f=D%3a\TvTemp\Serbian News_2_20090412_09301000.ts -dram 1 -single
execute /bin/mono.real Array
/bin/mono.real '-nogui' 'http://192.168.1.1:7647/stream?f=D%3a\TvTemp\Serbian News_2_20090412_09301000.ts' '-dram' '1' '-single'
Starting /bin/mono.real '-nogui' 'http://192.168.1.1:7647/stream?f=D%3a\TvTemp\Serbian News_2_20090412_09301000.ts' '-dram' '1' '-single'
/bin/mono.real '-nogui' 'http://192.168.1.1:7647/stream?f=D%3a\TvTemp\Serbian News_2_20090412_09301000.ts' '-dram' '1' '-single' Exited with return status of 0
Saving mono settings for incase of reboot

Starting Mono.Wrapper: /bin/mono -nogui http://192.168.1.1:7647/stream?f=D%3a\TvTemp\Scrapheap Challenge_2_20090412_09201010.ts -dram 1 -single
execute /bin/mono.real Array
/bin/mono.real '-nogui' 'http://192.168.1.1:7647/stream?f=D%3a\TvTemp\Scrapheap Challenge_2_20090412_09201010.ts' '-dram' '1' '-single'
Starting /bin/mono.real '-nogui' 'http://192.168.1.1:7647/stream?f=D%3a\TvTemp\Scrapheap Challenge_2_20090412_09201010.ts' '-dram' '1' '-single'
/bin/mono.real '-nogui' 'http://192.168.1.1:7647/stream?f=D%3a\TvTemp\Scrapheap Challenge_2_20090412_09201010.ts' '-dram' '1' '-single' Exited with return status of 0
Saving mono settings for incase of reboot

Starting Mono.Wrapper: /bin/mono -nogui http://192.168.1.1:7647/stream?f=D%3a\TvTemp\Today on Sunday_2_20090412_07001000.ts -dram 1 -single
execute /bin/mono.real Array
/bin/mono.real '-nogui' 'http://192.168.1.1:7647/stream?f=D%3a\TvTemp\Today on Sunday_2_20090412_07001000.ts' '-dram' '1' '-single'
Starting /bin/mono.real '-nogui' 'http://192.168.1.1:7647/stream?f=D%3a\TvTemp\Today on Sunday_2_20090412_07001000.ts' '-dram' '1' '-single'
/bin/mono.real '-nogui' 'http://192.168.1.1:7647/stream?f=D%3a\TvTemp\Today on Sunday_2_20090412_07001000.ts' '-dram' '1' '-single' Exited with return status of 0
Saving mono settings for incase of reboot

Starting Mono.Wrapper: /bin/mono -nogui http://192.168.1.1:7647/stream?f=D%3a\TvTemp\Weekend Sunrise_2_20090412_07001000.ts -dram 1 -single
execute /bin/mono.real Array
/bin/mono.real '-nogui' 'http://192.168.1.1:7647/stream?f=D%3a\TvTemp\Weekend Sunrise_2_20090412_07001000.ts' '-dram' '1' '-single'
Starting /bin/mono.real '-nogui' 'http://192.168.1.1:7647/stream?f=D%3a\TvTemp\Weekend Sunrise_2_20090412_07001000.ts' '-dram' '1' '-single'
/bin/mono.real '-nogui' 'http://192.168.1.1:7647/stream?f=D%3a\TvTemp\Weekend Sunrise_2_20090412_07001000.ts' '-dram' '1' '-single' Exited with return status of 0
Saving mono settings for incase of reboot

Starting Mono.Wrapper: /bin/mono -single file:///opt/sybhttpd/localhost.drives/HARD_DISK/Video/Ashlea/Dora The Explorer/Dora Season 2/212 - Pinto, the Pony Express.avi -dram 1
single
mountFilesystemByPath: file:///opt/sybhttpd/localhost.drives/HARD_DISK/Video/Ashlea/Dora The Explorer/Dora Season 2/212 - Pinto, the Pony Express.avi
Not a Network Share
execute /bin/mono.real Array
/bin/mono.real '-single' 'file:///opt/sybhttpd/localhost.drives/HARD_DISK/Video/Ashlea/Dora The Explorer/Dora Season 2/212 - Pinto, the Pony Express.avi' '-dram' '1'
Starting /bin/mono.real '-single' 'file:///opt/sybhttpd/localhost.drives/HARD_DISK/Video/Ashlea/Dora The Explorer/Dora Season 2/212 - Pinto, the Pony Express.avi' '-dram' '1'
/bin/mono.real '-single' 'file:///opt/sybhttpd/localhost.drives/HARD_DISK/Video/Ashlea/Dora The Explorer/Dora Season 2/212 - Pinto, the Pony Express.avi' '-dram' '1' Exited with return status of 0
Saving mono settings for incase of reboot

thanks
David


RE: On-Demand network share mounting - Ragnar - 04-12-2009 10:15 PM

(04-11-2009 04:12 PM)hxall Wrote:  I have been reporting this for a while that with 0.10 my HDTV would show "unsupported resolution," I would get audio but no video. This problem only occurred on my a-110 and not on my a-100. The difference probably has more to do with the fact that the a-110 is connected thru HDMI (1080p60) and the a-100 via component (1080i60).

Sorry you are having problems, but glad to see it's not just me...

Ok, owning an A110 also with HDMI (1080p60), maybe a place to start looking for an answer.
In the meantime, if you have local disks as storage, setting up a mounting point through diskmanagement does the trick. If you have, like I do, a combination of XP with one disk in the popcorn and one locally (pc) attached disk this won't work. In this case you need Vista and mklink to do this.


RE: On-Demand network share mounting - hxall - 04-13-2009 04:08 AM

(04-12-2009 10:15 PM)Ragnar Wrote:  Ok, owning an A110 also with HDMI (1080p60), maybe a place to start looking for an answer.
In the meantime, if you have local disks as storage, setting up a mounting point through diskmanagement does the trick. If you have, like I do, a combination of XP with one disk in the popcorn and one locally (pc) attached disk this won't work. In this case you need Vista and mklink to do this.
I have multiple servers (2 NAS), local HDD in both popcorns and a Vista PC with 2TB of storage, all with video content, so having auto mount is critical to make this seamless for family members when using the jukeboxes running in the NMTs.


RE: On-Demand network share mounting - starz - 04-16-2009 09:07 PM

Hi,
with the last update A-110 I have this problem : why ?

Code:
Starting Mono.Wrapper: /bin/mono -initialize
Restoring saved mono settings
mountFilesystemByName: false
Couldn't find /opt/sybhttpd/localhost.drives/NETWORK_SHARE/false in /proc/mounts
possible shares:     NAS Myibook
no matching share
Couldn't find /opt/sybhttpd/localhost.drives/NETWORK_SHARE/false in /proc/mounts
Mount Failed



RE: On-Demand network share mounting - espange - 04-23-2009 12:16 AM

I was wondering if this works for the Video_TS structures as well?


thanks


RE: On-Demand network share mounting - jokster - 04-26-2009 05:04 PM

thanks for a very nice useful app

one thing - i was looking into a custom index for the pch, jukeboxes (stored on internal HD) all work perfectly but when i try browse to folders (my tv and music have no indexes) through the index, i get a no content found error. i assume this is because the shares havent been mounted, but as i am linking to them from an index i thought they would have mounted as they were loaded as nothing special is going on here. maybe its an index problem.
if anyone has any thoughs i'd appreciate the help.

once again thanks to journey4712 for all the work

EDIT
after a bit of investigating i have found that if i browse to either my music or tv folder then go back into the index it works - so it does seem to be a mount problem.
also YAMJs play all (cd1, cd2 split avi) no longer works


RE: On-Demand network share mounting - Sluuz - 04-26-2009 07:56 PM

Hi Journey,

really appreciate your efforts, but I can't get Mono Wrapper to function properly.

I have added two shares on my HDX1000:
  • Series (192.168.1.20:/volumes/my%20book/muziek/itunes/itunes%20music/tv%20shows)
  • Films (192.168.1.20:/volumes/my%20book/films)


Both of which are nfs shares. When I manually mount these shares all goes well and the files on each share start playing correctly.

When I start YAMJ (which resides on the HDX's internal HD), I can only play files on one of the shares (the last one I mounted manually).

My YAMJ libraries.xml file looks like this:

Code:
<libraries>
    <library>
        <path>/volumes/My Book/Muziek/iTunes/iTunes Music/TV Shows</path>
        <nmtpath>file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/Series
        </nmtpath>
        <exclude name="sample,tmp/,temp/,RECYCLE.BIN/"/>
        <description></description>
        <prebuf></prebuf>
        <scrapeLibrary>true</scrapeLibrary>
    </library>

    <library>
        <path>/volumes/My Book/Films</path>
        <nmtpath>file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/Films</nmtpath>
        <exclude name="sample,tmp/,temp/,RECYCLE.BIN/"/>
        <description></description>
        <prebuf></prebuf>
        <scrapeLibrary>true</scrapeLibrary>
    </library>

My Mono log contains the following

Code:
Starting Mono.Wrapper: /bin/mono -initialize
Restoring saved mono settings
No mono_settings to load from /opt/sybhttpd/localhost.drives/HARD_DISK/Apps/Mono.Wrapper/saved.settings
No share to mount on boot

Starting Mono.Wrapper: /bin/mono -single file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/Films/THE_WRESTLER_1080P_X264_NLSUBBED_JUST4FUN_TEAM.mkv -dram 1
single
mountFilesystemByPath: file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/Films/THE_WRESTLER_1080P_X264_NLSUBBED_JUST4FUN_TEAM.mkv
mountFilesystemByName: Films
Couldn't find /opt/sybhttpd/localhost.drives/NETWORK_SHARE/Films in /proc/mounts
performing mount: smb.cmd=mount&smb.opt=nfs%3A%2F%2Fimac%3A%2Fvolumes%2Fmy%2520book%2Ffilms&smb.user=******&smb.passwd=******&smb.name=Films

Starting Mount.Wrapper: /bin/mount -t nfs -o soft,nolock,rw,rsize=32768,wsize=32768,retry=1,udp 192.168.1.20:/volumes/my%20book/films /opt/sybhttpd/localhost.drives/NETWORK_SHARE/Films
Unrecognized command line options
executeMount
execute /bin/busybox mount Array
/bin/busybox mount '-t' 'nfs' '-o' 'soft,nolock,rw,rsize=32768,wsize=32768,retry=1,udp' '192.168.1.20:/volumes/my%20book/films' '/opt/sybhttpd/localhost.drives/NETWORK_SHARE/Films'
Starting /bin/busybox mount '-t' 'nfs' '-o' 'soft,nolock,rw,rsize=32768,wsize=32768,retry=1,udp' '192.168.1.20:/volumes/my%20book/films' '/opt/sybhttpd/localhost.drives/NETWORK_SHARE/Films'
Couldn't find /opt/sybhttpd/localhost.drives/NETWORK_SHARE/Films in /proc/mounts
Mount Failed.
execute /bin/mono.real Array
/bin/mono.real '-single' 'file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/Films/THE_WRESTLER_1080P_X264_NLSUBBED_JUST4FUN_TEAM.mkv' '-dram' '1'
Starting /bin/mono.real '-single' 'file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/Films/THE_WRESTLER_1080P_X264_NLSUBBED_JUST4FUN_TEAM.mkv' '-dram' '1'
/bin/mono.real '-single' 'file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/Films/THE_WRESTLER_1080P_X264_NLSUBBED_JUST4FUN_TEAM.mkv' '-dram' '1' Exited with return status of 255
Saving mono settings for incase of reboot

Starting Mono.Wrapper: /bin/mono -single file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/Series/Two And A Half Men/Two And A Half Men S06E06.m4v -dram 1
single
mountFilesystemByPath: file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/Series/Two And A Half Men/Two And A Half Men S06E06.m4v
mountFilesystemByName: Series
Couldn't find /opt/sybhttpd/localhost.drives/NETWORK_SHARE/Series in /proc/mounts
performing mount: smb.cmd=mount&smb.opt=nfs%3A%2F%2Fimac%3A%2Fvolumes%2Fmy%20book%2Fmuziek%2Fitunes%2Fitunes​%2520music%2Ftv%2520shows&smb.user=TimFranken&smb.passwd=0362026&smb.name=Series

Starting Mount.Wrapper: /bin/mount -t nfs -o soft,nolock,rw,rsize=32768,wsize=32768,retry=1,udp 192.168.1.20:/volumes/my book/muziek/itunes/itunes%20music/tv%20shows /opt/sybhttpd/localhost.drives/NETWORK_SHARE/Series
Unrecognized command line options
executeMount
execute /bin/busybox mount Array
/bin/busybox mount '-t' 'nfs' '-o' 'soft,nolock,rw,rsize=32768,wsize=32768,retry=1,udp' '192.168.1.20:/volumes/my book/muziek/itunes/itunes%20music/tv%20shows' '/opt/sybhttpd/localhost.drives/NETWORK_SHARE/Series'
Starting /bin/busybox mount '-t' 'nfs' '-o' 'soft,nolock,rw,rsize=32768,wsize=32768,retry=1,udp' '192.168.1.20:/volumes/my book/muziek/itunes/itunes%20music/tv%20shows' '/opt/sybhttpd/localhost.drives/NETWORK_SHARE/Series'
Couldn't find /opt/sybhttpd/localhost.drives/NETWORK_SHARE/Series in /proc/mounts
Mount Failed.
execute /bin/mono.real Array
/bin/mono.real '-single' 'file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/Series/Two And A Half Men/Two And A Half Men S06E06.m4v' '-dram' '1'
Starting /bin/mono.real '-single' 'file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/Series/Two And A Half Men/Two And A Half Men S06E06.m4v' '-dram' '1'
/bin/mono.real '-single' 'file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/Series/Two And A Half Men/Two And A Half Men S06E06.m4v' '-dram' '1' Exited with return status of 255
Saving mono settings for incase of reboot

Starting Mount.Wrapper: /bin/mount -t nfs -o soft,nolock,rw,rsize=32768,wsize=32768,retry=1,udp 192.168.1.20:/volumes/my book/muziek/itunes/itunes music/tv shows /opt/sybhttpd/localhost.drives/NETWORK_SHARE/Series
Unrecognized command line options
executeMount
execute /bin/busybox mount Array
/bin/busybox mount '-t' 'nfs' '-o' 'soft,nolock,rw,rsize=32768,wsize=32768,retry=1,udp' '192.168.1.20:/volumes/my book/muziek/itunes/itunes music/tv shows' '/opt/sybhttpd/localhost.drives/NETWORK_SHARE/Series'
Starting /bin/busybox mount '-t' 'nfs' '-o' 'soft,nolock,rw,rsize=32768,wsize=32768,retry=1,udp' '192.168.1.20:/volumes/my book/muziek/itunes/itunes music/tv shows' '/opt/sybhttpd/localhost.drives/NETWORK_SHARE/Series'

Starting Mono.Wrapper: /bin/mono -single file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/Series/Two And A Half Men/Two And A Half Men S06E06.m4v -dram 1
single
mountFilesystemByPath: file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/Series/Two And A Half Men/Two And A Half Men S06E06.m4v
mountFilesystemByName: Series
Series already mounted
Mount Success.
execute /bin/mono.real Array
/bin/mono.real '-single' 'file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/Series/Two And A Half Men/Two And A Half Men S06E06.m4v' '-dram' '1'
Starting /bin/mono.real '-single' 'file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/Series/Two And A Half Men/Two And A Half Men S06E06.m4v' '-dram' '1'
/bin/mono.real '-single' 'file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/Series/Two And A Half Men/Two And A Half Men S06E06.m4v' '-dram' '1' Exited with return status of 0
Saving mono settings for incase of reboot

Starting Mono.Wrapper: /bin/mono -single file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/Series/Two And A Half Men/Two And A Half Men S06E06.m4v -dram 1
single
mountFilesystemByPath: file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/Series/Two And A Half Men/Two And A Half Men S06E06.m4v
mountFilesystemByName: Series
Series already mounted
Mount Success.
execute /bin/mono.real Array
/bin/mono.real '-single' 'file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/Series/Two And A Half Men/Two And A Half Men S06E06.m4v' '-dram' '1'
Starting /bin/mono.real '-single' 'file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/Series/Two And A Half Men/Two And A Half Men S06E06.m4v' '-dram' '1'
/bin/mono.real '-single' 'file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/Series/Two And A Half Men/Two And A Half Men S06E06.m4v' '-dram' '1' Exited with return status of 0
Saving mono settings for incase of reboot

Starting Mono.Wrapper: /bin/mono -single file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/Series/Two And A Half Men/Two And A Half Men S06E07.m4v -dram 1
single
mountFilesystemByPath: file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/Series/Two And A Half Men/Two And A Half Men S06E07.m4v
mountFilesystemByName: Series
Series already mounted
Mount Success.
execute /bin/mono.real Array
/bin/mono.real '-single' 'file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/Series/Two And A Half Men/Two And A Half Men S06E07.m4v' '-dram' '1'
Starting /bin/mono.real '-single' 'file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/Series/Two And A Half Men/Two And A Half Men S06E07.m4v' '-dram' '1'
/bin/mono.real '-single' 'file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/Series/Two And A Half Men/Two And A Half Men S06E07.m4v' '-dram' '1' Exited with return status of 0
Saving mono settings for incase of reboot

What did I do wrong?


RE: On-Demand network share mounting - zertyx - 04-27-2009 09:28 AM

(04-12-2009 10:15 PM)Ragnar Wrote:  Ok, owning an A110 also with HDMI (1080p60), maybe a place to start looking for an answer.
In the meantime, if you have local disks as storage, setting up a mounting point through diskmanagement does the trick. If you have, like I do, a combination of XP with one disk in the popcorn and one locally (pc) attached disk this won't work. In this case you need Vista and mklink to do this.

I have the same problem here: A110 with HDMI, and 'unsupported resolution' when I install Mono.wrapper


RE: On-Demand network share mounting - hxall - 04-27-2009 09:38 PM

(04-27-2009 09:28 AM)zertyx Wrote:  I have the same problem here: A110 with HDMI, and 'unsupported resolution' when I install Mono.wrapper

okay, so that's 3 of us with similar setup getting the same results...

@journey, can you help us with this? any plans for someone else picking up this development, I'm surprised syabas doesn't provide this option directly rather than thru the user community...


RE: On-Demand network share mounting - hxall - 04-29-2009 03:33 AM

(04-29-2009 12:09 AM)scotty144 Wrote:  I have had this working flawlessly for the last couple of months on my 3 popcornhours with internal drives. Now that the drives are all full I am trying to get monowrapper to work without success on my pc drives as well. Am I unable to do this with the program?

you need to be more specific, what has been working flawlessly? are you able to stream from any pch to the others using a jukebox and monowrapper? the only problems reported are with auto mounting shares when it involves isos, what specifically are you having trouble with?