Firmware: A-410 [01 Apr. 2014] | A-400 [12 Mar. 2014] | C-300 [13 Feb. 2014] | A-300 [24 Feb. 2014] | C-200 [11 July 2013] | A-200/A-210 [11 July 2013] | Popbox V8 [3 Dec 2013]

Just got your NMT | WIKI has the answers | Search the forum | Forum Rules/Policy | Firmware & Official NMT News | Popcornhour manuals



User(s) browsing this thread: 1 Guest(s)
Post Reply 
[Bug] A-300 Wakes On Lan a computer!
04-15-2012, 06:41 AM
Post: #16
RE: A-300 Wakes On Lan a computer!
glad you found that problem.
Find all posts by this user
Add Thank You Quote this message in a reply
04-15-2012, 06:48 AM
Post: #17
RE: A-300 Wakes On Lan a computer!
the only place I remember away mode being was in the power management profiles but there is probably more settings.
Find all posts by this user
Add Thank You Quote this message in a reply
04-15-2012, 06:41 PM (This post was last modified: 04-15-2012 06:45 PM by Tolik.)
Post: #18
RE: A-300 Wakes On Lan a computer!
Although we found out that it was not WOL there is a bug anyway.
When the computer is down A-300 sometimes is waiting for too long before opening Local Media.
It shows red sign on Local Media icon for about 1 minute! while local drives are ready.
This is absolutely not logical and really annoying.

As I wrote before it also waits for long time on df -h command. Look, 55 seconds for nothing:
Code:
sh-3.00# mount
rootfs on / type rootfs (rw)
proc on /proc type proc (rw)
usbfs on /proc/bus/usb type usbfs (rw)
sysfs on /sys type sysfs (rw)
tmpfs on /tmp type tmpfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/mtdblock13 on /opt/syb type squashfs (ro)
/dev/mtdblock15 on /opt/syb/local type romfs (ro)
/dev/mtdblock11 on /opt/syb/usr type yaffs2 (rw,noatime,nodiratime)
/dev/mtdblock14 on /opt/syb/share type squashfs (ro)
/dev/mtdblock12 on /mnt type yaffs2 (rw,noatime,nodiratime)
/dev/sda1 on /opt/sybhttpd/localhost.drives/SATA_DISK_a08f247f-7c86-4069-866d-26308a5576a01 type ext3 (rw,noatime,nodiratime,errors=continue,data=ordered)
/dev/sdb2 on /persistfs type ext3 (rw,noatime,nodiratime,errors=continue,data=ordered)
/dev/sdb1 on /nmt type ext3 (rw,noatime,nodiratime,errors=continue,data=ordered)
/dev/sdb3 on /opt/sybhttpd/localhost.drives/USB_DRIVE type ext3 (rw,noatime,nodiratime,errors=continue,data=ordered)
//192.168.1.33/Video_4 on /opt/sybhttpd/localhost.drives/NETWORK_SHARE/share1 type cifs (rw,noatime,nodiratime,unc=\192.168.1.33\Video_4,username=root,addr=192.168.1.33​,uid=0,gid=0,file_mode=02767,dir_mode=0777,rsize=61440,wsize=130048)
//192.168.1.33/Video_3 on /opt/sybhttpd/localhost.drives/NETWORK_SHARE/share2 type cifs (rw,noatime,nodiratime,unc=\192.168.1.33\Video_3,username=root,addr=192.168.1.33​,uid=0,gid=0,file_mode=02767,dir_mode=0777,rsize=61440,wsize=130048)
sh-3.00# time df -h
Filesystem                Size      Used Available Use% Mounted on
tmpfs                    93.1M    608.0K     92.5M   1% /tmp
/dev/mtdblock13          26.9M     26.9M         0 100% /opt/syb
/dev/mtdblock15          19.5M     19.5M         0 100% /opt/syb/local
/dev/mtdblock11         118.1M      6.2M    111.9M   5% /opt/syb/usr
/dev/mtdblock14          13.9M     13.9M         0 100% /opt/syb/share
/dev/mtdblock12           7.9M      1.1M      6.8M  14% /mnt
/dev/sda1                 1.8T    246.7G      1.5T  14% /opt/sybhttpd/localhost.drives/SATA_DISK_a08f247f-7c86-4069-866d-26308a5576a01
/dev/sdb2                 1.8G     32.1M      1.8G   2% /persistfs
/dev/sdb1               949.6M     61.0M    888.6M   6% /nmt
/dev/sdb3                 4.7G    136.1M      4.6G   3% /opt/sybhttpd/localhost.drives/USB_DRIVE

real    0m55.007s
user    0m0.000s
sys     0m0.010s
sh-3.00#

I guess there is df command in the A-300 code indeed. Funny that it does not show free space on disks after that.
Find all posts by this user
Add Thank You Quote this message in a reply
06-03-2012, 04:25 AM
Post: #19
RE: A-300 Wakes On Lan a computer!
I'm really tired of this red road sign so I added a command to crontab to remove all network shares every night:
Code:
A300[/]# cat /etc/cron/cron.daily

/bin/umount /opt/sybhttpd/localhost.drives/NETWORK_SHARE/share*

Of course this line is added by a startup script.

Please fix this bug!
Find all posts by this user
Add Thank You Quote this message in a reply
06-08-2012, 06:56 PM
Post: #20
RE: A-300 Wakes On Lan a computer!
After a while I noticed that red sign on Local Media icon appears every day, not occasionally as before.
Even without network shares it takes quite a while to... Huh.

So I came to a conclusion that every change to mount tab (even attempt to unmount non-existing mounts) triggers some stupid process that rechecks all disks. (I remember, accident and halfelite have told something about it).

So I had to get rid of my bright idea (in previous post). Any idea how to kill that stupid process?
Find all posts by this user
Add Thank You Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  [Bug] Loses mapping to computer after being off. skeeto 1 486 04-22-2013 12:52 PM
Last Post: Tolik

Forum Jump: