Firmware: A-410 [01 Apr. 2014] | A-400 [12 Mar. 2014] | C-300 [13 Feb. 2014] | A-300 [24 Feb. 2014] | C-200 [11 July 2013] | A-200/A-210 [11 July 2013] | Popbox V8 [3 Dec 2013]

Just got your NMT | WIKI has the answers | Search the forum | Forum Rules/Policy | Firmware & Official NMT News | Popcornhour manuals



User(s) browsing this thread:
Post Reply 
[PHOTO] PhotoJukebox Release 1
12-23-2011, 07:54 PM
Post: #106
RE: [PHOTO] PhotoJukebox Release 1
(12-23-2011 06:29 PM)PaaDii Wrote:  Yea Sure.

Code:
[PhotoJukebox]

; title for this photo jukebox
str_title = Life of Caldersparr/Åström

Ok. I know the Photojukebox contains a minor bug in parsing unicode characters in the config file, and I suspect it's triggering the problem you are experiencing. I'm not at home right now, so I can't verify it.

Can you try and change the title for the Jukebox (str_title) to something with regular (no accented) characters?

Let me know if that helps.
Find all posts by this user
Add Thank You Quote this message in a reply
[+] 1 user says Thank You to wim-pch200 for this post
12-24-2011, 08:58 AM
Post: #107
RE: [PHOTO] PhotoJukebox Release 1
That did the trick. Removed Caldersparr/Åström and it worked like a charm.
Thanks Smile
Find all posts by this user
Add Thank You Quote this message in a reply
01-09-2012, 08:51 PM
Post: #108
RE: [PHOTO] PhotoJukebox Release 1
is this suitable for the A300, cause when i browse to the folder the photos.html file is not showing up. thanks
Find all posts by this user
Add Thank You Quote this message in a reply
01-09-2012, 09:18 PM
Post: #109
RE: [PHOTO] PhotoJukebox Release 1
(01-09-2012 08:51 PM)Flussig Wrote:  is this suitable for the A300, cause when i browse to the folder the photos.html file is not showing up. thanks

The A300 is using a FLASH based interface, and does not support a HTML based interface.

I'm working on a FLASH based interface, but that'll need some more time before finished.

Regards,
Wim.
Find all posts by this user
Add Thank You Quote this message in a reply
[+] 1 user says Thank You to wim-pch200 for this post
01-09-2012, 09:20 PM
Post: #110
RE: [PHOTO] PhotoJukebox Release 1
(01-09-2012 09:18 PM)wim-pch200 Wrote:  
(01-09-2012 08:51 PM)Flussig Wrote:  is this suitable for the A300, cause when i browse to the folder the photos.html file is not showing up. thanks

The A300 is using a FLASH based interface, and does not support a HTML based interface.

I'm working on a FLASH based interface, but that'll need some more time before finished.

Regards,
Wim.



ah ok, thanks
Find all posts by this user
Add Thank You Quote this message in a reply
01-12-2012, 06:51 PM (This post was last modified: 01-12-2012 07:29 PM by JPM39.)
Post: #111
RE: [PHOTO] PhotoJukebox Release 1
Hello,

I tried to upgrade v1.3 to v1.4.1 but could'nt run it. I modified the new config file according to the old one but when i try to generate the jukebox i got this error message: missing configuration value for 'str_page'.
Could you let me know where i made a mistake....
Thanks by advance.

Regards,

JP
(01-12-2012 06:51 PM)JPM39 Wrote:  Hello,

I tried to upgrade v1.3 to v1.4.1 but could'nt run it. I modified the new config file according to the old one but when i try to generate the jukebox i got this error message: missing configuration value for 'str_page'.
Could you let me know where i made a mistake....
Thanks by advance.

Regards,

JP

I found out my mistake due to a stupid copy of the language file from v1.3 to v1.4
Thanks for your job
JP
Find all posts by this user
Add Thank You Quote this message in a reply
03-11-2012, 06:39 PM
Post: #112
RE: [PHOTO] PhotoJukebox Release 1
Howdy,

I've run generate_photojukebox around 5 times now to test out the config. Three times, my output directory was deleted. The other two, everything worked out fine.

What would be causing the deletion of the output directory?

Also, I'm assuming that everytime I add new pictures, I'll have to run generate_photojukebox, correct? Will it then rescan everything (all 30,000+ pics all over again)?

Thanks. Nice program overall.
Find all posts by this user
Add Thank You Quote this message in a reply
03-12-2012, 08:33 AM
Post: #113
RE: [PHOTO] PhotoJukebox Release 1
(03-11-2012 06:39 PM)DonMuraco Wrote:  Howdy,

I've run generate_photojukebox around 5 times now to test out the config. Three times, my output directory was deleted. The other two, everything worked out fine.

What would be causing the deletion of the output directory?

Also, I'm assuming that everytime I add new pictures, I'll have to run generate_photojukebox, correct? Will it then rescan everything (all 30,000+ pics all over again)?

Thanks. Nice program overall.

It will always delete the output folder, before copying the new contents over. Just to keep a clean output folder, without any "old" files lingering.

Did you get any error message when you got an empty output directory?
If not, you can turn on debugging (check the config file), and post the contents of the logfile.

Yes, you will need to run generate_photojukebox.bat every time after adding/removing pictures, and it will rescan everything again. But it only needs to generate thumbs for new pictures, because thumbs will be retained between program runs. (unless you decide to remove the temp output folder below the program files manually).
Find all posts by this user
Add Thank You Quote this message in a reply
03-13-2012, 01:52 AM
Post: #114
RE: [PHOTO] PhotoJukebox Release 1
(03-12-2012 08:33 AM)wim-pch200 Wrote:  It will always delete the output folder, before copying the new contents over. Just to keep a clean output folder, without any "old" files lingering.

Did you get any error message when you got an empty output directory?
If not, you can turn on debugging (check the config file), and post the contents of the logfile.

No error message and I'm not seeing anything in the log file. The program runs through the process, and right near the end I can see the files in my JukeboxPictures folder. When the program closes, the JukeboxPictures folder is gone. So now I'm just copying the contents from the Progam directory output folder into my jukebox folder which i recreate after deletion.

Don't know if there's anything else to check or something I should be doing differently.

Another question - is there an easier way to get back to my index.file vs pressing exit many times (depending how many pages I've navigated through in my photo jukebox)?

Thanks.
Find all posts by this user
Add Thank You Quote this message in a reply
03-13-2012, 03:39 PM
Post: #115
RE: [PHOTO] PhotoJukebox Release 1
(03-13-2012 01:52 AM)DonMuraco Wrote:  No error message and I'm not seeing anything in the log file. The program runs through the process, and right near the end I can see the files in my JukeboxPictures folder. When the program closes, the JukeboxPictures folder is gone. So now I'm just copying the contents from the Progam directory output folder into my jukebox folder which i recreate after deletion.

Don't know if there's anything else to check or something I should be doing differently.

Another question - is there an easier way to get back to my index.file vs pressing exit many times (depending how many pages I've navigated through in my photo jukebox)?

Thanks.

Hmm, you mean the logfile is empty? Or it doesn't contain anything related to this problem?
Output folder is cleared, just before the new contents is copied over.

The last 3 lines of output on screen should be like:
Code:
copying skin files...
copying output files...
done.

Output will remain visible when started from a command prompt:
open a command prompt, cd into the folder of the photojukebox, and start: generate_photojukebox.bat.

Regarding returning to the index: You can try to hit the "Home" button on the remote, or the "Home" icon at the right top corner.

Edit: I have been using my Harmony remote so long, that I only just noticed that the remote for the Popcorn Hour C200 does not have a Home button.

Next version will include an option to configure which key will be used to get to the main index file...
Find all posts by this user
Add Thank You Quote this message in a reply
07-08-2012, 10:04 AM
Post: #116
RE: [PHOTO] PhotoJukebox Release 1
Dear Wim,


Do you already have anything for the A-300 ready?

Thanks for the info.


Best regards
Find all posts by this user
Add Thank You Quote this message in a reply
07-12-2012, 12:47 PM
Post: #117
RE: [PHOTO] PhotoJukebox Release 1
(07-08-2012 10:04 AM)Henky123 Wrote:  Dear Wim,

Do you already have anything for the A-300 ready?

Thanks for the info.

Best regards

Sorry, not yet. Haven't had time to do much on it.
Hope to get more time after the summer break.
Find all posts by this user
Add Thank You Quote this message in a reply
07-26-2012, 12:31 AM
Post: #118
RE: [PHOTO] PhotoJukebox Release 1
Hi, i run this on my popcorn the html is to big for my sd tV, how can i config to downsize the html?
and when play the photos leaves me in the image in transparency "loading"

Thanks
Juan
Find all posts by this user
Add Thank You Quote this message in a reply
07-27-2012, 07:45 AM
Post: #119
RE: [PHOTO] PhotoJukebox Release 1
(07-26-2012 12:31 AM)jplinux3 Wrote:  Hi, i run this on my popcorn the html is to big for my sd tV, how can i config to downsize the html?
and when play the photos leaves me in the image in transparency "loading"

Thanks
Juan

Hi Juan,

What exactly is "too big on my sd tv"?

You can limit the number of rows on each page by editing the config file, search for: max_rows_per_page.

Or is the text too large? too far to the right?
Can you post a picture, so i can see how it looks like on your TV?

Regarding not showing any pictures: this is usually caused by a wrong path setting in the config file.
What device do you have? Are the pictures stored on your device? Or on a separate device, like a NAS?
Can you post the relevant settings of your config file?
(all path related lines)

Regards,

Wim.
Find all posts by this user
Add Thank You Quote this message in a reply
07-28-2012, 12:34 AM
Post: #120
RE: [PHOTO] PhotoJukebox Release 1
In the index i dont see the preview thumb and only to the 6 on the list.

My config

photodir_pc = C:\Users\Juanymay\Pictures
photodir_popcorn = /opt/sybhttpd/localhost.drives/NETWORK_SHARE/pic/
outputdir_pc = J:\Video\menu\Pictures\
outputdir_popcorn = /opt/sybhttpd/localhost.drives/HARD_DISK/Video/menu/Pictures/
Find all posts by this user
Add Thank You Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
Information [MUSIC] Music Jukebox Release 8 Download and Installation wandidj 1,492 638,961 03-18-2014 10:19 PM
Last Post: yetiboy
  [plexNMT] Beta Release, Download and Install rip77 118 27,496 10-12-2013 10:36 AM
Last Post: Atinkler
Brick [plexNMT] Alpha Testing Release, Download and Installation rip77 117 30,317 05-18-2013 03:19 PM
Last Post: Switchblade
  [plexNMT] Alpha Release 2, Download and Installation rip77 71 15,278 03-29-2013 02:48 PM
Last Post: qukquk
Exclamation [PHOTO] Generate html photo album PWijnberg 10 9,269 09-07-2012 06:45 PM
Last Post: Franco1s
  [PHOTO] uPNP client Photo Jukebox spud 0 2,035 05-02-2012 02:43 PM
Last Post: spud
  [AUDIO] Flac files Release date Unknown Bergkamp 0 1,266 02-24-2012 09:52 PM
Last Post: Bergkamp
  Photo Flow Jukebox 08-12-2011 michael1t 1 3,149 08-28-2011 02:24 PM
Last Post: michael1t
Video Grawler - ** Update 02-03-2011 ** - Alpha 1 release devnl 27 9,632 03-15-2011 10:38 AM
Last Post: devnl
  [PHOTO] [MUSIC] JLRutaMJB skin for photo and MusicJukebox - using MJB R8 jluc2808 187 95,604 01-17-2011 11:57 PM
Last Post: Penge58

Forum Jump: