Firmware: A-410 [01 Apr. 2014] | A-400 [12 Mar. 2014] | C-300 [13 Feb. 2014] | A-300 [24 Feb. 2014] | C-200 [11 July 2013] | A-200/A-210 [11 July 2013] | Popbox V8 [3 Dec 2013]

Just got your NMT | WIKI has the answers | Search the forum | Forum Rules/Policy | Firmware & Official NMT News | Popcornhour manuals



User(s) browsing this thread: 1 Guest(s)
Thread Closed 
Llink - not showing rar files
12-06-2008, 07:51 PM
Post: #1
Llink - not showing rar files
Ik have installed and am running Llink from my Windows Home Server (WHS).

Everything seems to be working fine, except...

it does not show any rar-files.

I have lots of movies "STORED" in multiple rar files linke

moviexxxx.rar
moviexxxx.r00
moviexxxx.r01
moviexxxx.r02

The only thin I changed in llink.conf is the ROOT-path so it matches the correct directory for the movies on my server.

please advise...

Setup:
- HDX1000 (500GB, no movies stored);
- Windows Home Server, 750GB, for storing movies an tv-series.
- 100 MB/s UTP network
- Sony STR-DG 700 digital receiver
- Philips 47" ambilight LCD TV
Find all posts by this user
12-06-2008, 09:22 PM
Post: #2
RE: Llink - not showing rar files
What version of llink are you using?

In the latest 2.2.0 I think llink defaults to auto-open rar and iso/img files to display the contents directly. But it's hard to tell if that is your case.

Audio, video, disco - I hear, I see, I learn.
Wiki. Wiki? Wiki!
Find all posts by this user
12-06-2008, 09:55 PM
Post: #3
RE: Llink - not showing rar files
(12-06-2008 09:22 PM)dc11ab Wrote:  What version of llink are you using?

In the latest 2.2.0 I think llink defaults to auto-open rar and iso/img files to display the contents directly. But it's hard to tell if that is your case.

I am using the latest, downloaded today. version 2.2.0

It shows an empty folder if there is a rarred movie inside.

Setup:
- HDX1000 (500GB, no movies stored);
- Windows Home Server, 750GB, for storing movies an tv-series.
- 100 MB/s UTP network
- Sony STR-DG 700 digital receiver
- Philips 47" ambilight LCD TV
Find all posts by this user
12-07-2008, 12:44 AM
Post: #4
RE: Llink - not showing rar files
Try running llink from command prompt with:

llinkd.exe -v 8
or
llink.exe -v 8

(should show debug messages for unrar)

Audio, video, disco - I hear, I see, I learn.
Wiki. Wiki? Wiki!
Find all posts by this user
12-07-2008, 02:25 PM
Post: #5
RE: Llink - not showing rar files
(12-07-2008 12:44 AM)dc11ab Wrote:  Try running llink from command prompt with:

llinkd.exe -v 8
or
llink.exe -v 8

(should show debug messages for unrar)

Ik will do that. Something I noticed yesterdaynight, is what is hapening to another user in this topic.

some folder with rarred movies are showing and playing. And some are not.

this one does:
cocain-27d.rar
cocain-27d.r00
cocain-27d.r01
etc.

this one doesnot:
21-tlo.rar
21-tlo.r00
21-tlo.r01
etc.

Setup:
- HDX1000 (500GB, no movies stored);
- Windows Home Server, 750GB, for storing movies an tv-series.
- 100 MB/s UTP network
- Sony STR-DG 700 digital receiver
- Philips 47" ambilight LCD TV
Find all posts by this user
12-07-2008, 05:05 PM
Post: #6
RE: Llink - not showing rar files
Perhaps you can spot a pattern, for instance if the ones that doesn't work always contain iso or img, or mkv or some other container. Or if the ones that doesn't work contain more than one file etc.

Audio, video, disco - I hear, I see, I learn.
Wiki. Wiki? Wiki!
Find all posts by this user
12-07-2008, 09:08 PM
Post: #7
RE: Llink - not showing rar files
Couldnt you open the files in winrar and post the structure?

Im quite sure the problem is that the rar's contain a folder with the movie inside...

PCH-A100 (beta fw) + PCH-C200
Streaming from ReadyNas (llink and nfs)
Sony 40-x3500 TV
Visit this user's website Find all posts by this user
12-07-2008, 09:17 PM
Post: #8
RE: Llink - not showing rar files
1.
I foud a part of the problem.

Directorynames with () or SPACES in them, will not show a rarred-movie file.

If I replace the () and SPACES with dots, then the file shows.

It just not yet plays them. Movie starts, but shows only black screen.

2.
What I am also looking for are the "unrar-3.7.8-seek" files, that Lundman is talking about. Where can I find these? I only have the unrar.exe....but no "unrar-3.7.8-seek"
please advise

Setup:
- HDX1000 (500GB, no movies stored);
- Windows Home Server, 750GB, for storing movies an tv-series.
- 100 MB/s UTP network
- Sony STR-DG 700 digital receiver
- Philips 47" ambilight LCD TV
Find all posts by this user
12-07-2008, 09:22 PM (This post was last modified: 12-07-2008 09:22 PM by PoPEye.)
Post: #9
RE: Llink - not showing rar files
"2. What I am also looking for are the "unrar-3.7.8-seek" files, that Lundman is talking about. Where can I find these? I only have the unrar.exe....but no "unrar-3.7.8-seek"
please advise "
it is the unrar.exe

PCH-A100 (beta fw) + PCH-C200
Streaming from ReadyNas (llink and nfs)
Sony 40-x3500 TV
Visit this user's website Find all posts by this user
12-07-2008, 09:57 PM
Post: #10
RE: Llink - not showing rar files
(12-07-2008 09:22 PM)PoPEye Wrote:  "2. What I am also looking for are the "unrar-3.7.8-seek" files, that Lundman is talking about. Where can I find these? I only have the unrar.exe....but no "unrar-3.7.8-seek"
please advise "
it is the unrar.exe

thank you!

I have even more information. Did some more testing. And the () dont matter. The only thing that causes rar-movies not to be displayed is when there is a SPACE in the directoryname.

This is easy to solve for me. Just change the directory names. But since I have over a 100 movies, I'd rather see a different solution.

any ideas anybody?

Setup:
- HDX1000 (500GB, no movies stored);
- Windows Home Server, 750GB, for storing movies an tv-series.
- 100 MB/s UTP network
- Sony STR-DG 700 digital receiver
- Philips 47" ambilight LCD TV
Find all posts by this user
12-08-2008, 12:35 AM
Post: #11
RE: Llink - not showing rar files
I did a fair bit of testing against spaces, but that was in Unix world. Perhaps the parser for Windows needs a little fixing for spaces.
Visit this user's website Find all posts by this user
12-08-2008, 10:18 AM (This post was last modified: 12-08-2008 10:23 AM by dc11ab.)
Post: #12
RE: Llink - not showing rar files
kikkegek, If you can't wait for a possible fix there are options.

1. Get a program that does batch file renaming for you. Something like:
http://www.antp.be/software/renamer
http://www.publicspace.net/windows/Bette...index.html
http://www.safe-install.com/programs/han...-tool.html
http://www.softarea51.com/windows/System...ditor.html
http://www.fileheap.com/software-remove-...33763.html

I have not used a single one of them so download and install at own risk. The first one is made under the umbrella of a media catalog system (Ant) which your may find interesting and attractive to use for many other things too.

2. Write your own batch script to do it.
Maybe some regexpression + rename (or xcopy/del) command(s) in a .bat file. Use whatever script/language you and your WHS system support.

Audio, video, disco - I hear, I see, I learn.
Wiki. Wiki? Wiki!
Find all posts by this user
12-10-2008, 02:39 AM (This post was last modified: 12-10-2008 02:41 AM by quantum.)
Post: #13
RE: Llink - not showing rar files
I've been testing this. I have a DNS-323 NAS (Unix) running LLink and I also run LLink on a Windows PC. The NAS version handles every variation of RAR that I've tested so far. Spaces and folders are not a problem.

The Windows version has big trouble with spaces and folders. Any one of the following will cause the Windows version to fail to play on the NMT:
1=Spaces in path
2=Spaces in RAR archive file name
3=Spaces in file name contained in RAR archive
4=Folder contained in RAR archive

If all 4 of the above are not present, then it plays fine on the NMT from the Windows PC. Number 3 is the most difficult to fix, as it requires recreating the archive.

I'd be glad to help debug this. While I'm glad the NAS version works well, I'd like to see the Windows version have the same functionality.

Callisto - Series and Movies Organizer for NMT
Find all posts by this user
12-10-2008, 03:12 AM (This post was last modified: 12-10-2008 03:13 AM by lundman.)
Post: #14
RE: Llink - not showing rar files
Ok, as it happens the code that splits path into argv is completely different for Win32, so it is quite probable that it is incorrect. I will focus on this to get it fixed for spaces.
Visit this user's website Find all posts by this user
12-10-2008, 07:17 AM
Post: #15
RE: Llink - not showing rar files
@Quantum
glad you can confirm that it is not just me, having this problem.

@lundman
keep up the good work, wonderfull program. hope you can fix it. if you need testing done, I'll be glad to help!

Setup:
- HDX1000 (500GB, no movies stored);
- Windows Home Server, 750GB, for storing movies an tv-series.
- 100 MB/s UTP network
- Sony STR-DG 700 digital receiver
- Philips 47" ambilight LCD TV
Find all posts by this user
Thread Closed 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Llink 2.3.2 A-300 DubbelU 0 296 02-08-2014 11:46 AM
Last Post: DubbelU
  Announcing llink-2.3.2 release lundman 101 22,637 04-13-2013 05:33 AM
Last Post: HarmonyOne
  [A-400] Does not see llink server tkenn1s 5 2,195 02-26-2013 05:14 PM
Last Post: Imdre
  llink UPNP won't stream krylon 3 1,904 02-14-2013 03:43 AM
Last Post: lundman
  LLink question JoeDonth 5 1,492 01-04-2013 03:03 PM
Last Post: JoeDonth
  How to install Llink on C-300? hildyjohnson 2 1,475 08-10-2012 09:35 AM
Last Post: lundman
  200 series and live streaming and llink sugatam 3 2,123 05-06-2012 12:59 AM
Last Post: lundman
  Setup llink with A-300 PRS 9 3,170 04-24-2012 11:59 PM
Last Post: lundman
  What does this error in llink mean? litfoo 53 10,029 03-15-2012 03:42 AM
Last Post: lundman
  Llink on QNAP NAS working? litfoo 16 4,199 03-14-2012 08:19 PM
Last Post: gfb107

Forum Jump: