Firmware: A-410 [01 Apr. 2014] | A-400 [12 Mar. 2014] | C-300 [13 Feb. 2014] | A-300 [24 Feb. 2014] | C-200 [11 July 2013] | A-200/A-210 [11 July 2013] | Popbox V8 [3 Dec 2013]

Just got your NMT | WIKI has the answers | Search the forum | Forum Rules/Policy | Firmware & Official NMT News | Popcornhour manuals



User(s) browsing this thread: 2 Guest(s)
Thread Closed 
[CSI] Community Software Installer 2.6.1 (OLD THREAD)
05-21-2009, 06:39 PM
Post: #1066
RE: [CSI] *** PUBLIC *** Community Software Installer 2.1.5 (Windows/Linux/OSX)
(05-21-2009 06:37 PM)pac^man Wrote:  Ok, just did that. I had downloaded it already but as the file extension was .exe I didn't even try starting it.

The ftp settings are still gone after a restart.
But otherwise it works now, great!

The settings are removed during start on Mono because of an bug in Mono, the "start linux" script will actively remove the settings to make it work on mono.

Easy way of installing software on your NMT using just your mouse: NMT Community Software Installer
Visit this user's website Find all posts by this user
05-21-2009, 07:42 PM
Post: #1067
RE: [CSI] *** PUBLIC *** Community Software Installer 2.1.5 (Windows/Linux/OSX)
(05-21-2009 05:26 PM)Peppin Wrote:  Auto update to 2.1.5.0 went smooth and fast... props Smile

Same here. Updated without problems with ubuntu 9.04 and portable version.
Find all posts by this user
05-22-2009, 02:06 AM
Post: #1068
RE: [CSI] *** PUBLIC *** Community Software Installer 2.1.5 (Windows/Linux/OSX)
(05-21-2009 06:16 PM)Ger Teunis Wrote:  That is a known issue of 2.0.1.
Version 2.1.5 should fix that. We'll have to wait for Lundman to create a new DMG package which contains the 2.1.5 version.

You could also download 2.1.5 portable edition and start "Start Linux.sh". First you need to set the execute bit on it.

Done!

It appears mono-2.4 has issues on OsX, missing library. But perhaps it was just the one isolated case? Let me know if I should do some popups for detecting that.
Visit this user's website Find all posts by this user
05-22-2009, 10:50 AM
Post: #1069
RE: [CSI] *** PUBLIC *** Community Software Installer 2.1.5 (Windows/Linux/OSX)
(05-22-2009 02:06 AM)lundman Wrote:  Done!

It appears mono-2.4 has issues on OsX, missing library. But perhaps it was just the one isolated case? Let me know if I should do some popups for detecting that.

Thanks lundman.
Did you get it running on OSX or is Mono still complaining about a missing library? Could you give more info about the error?

Easy way of installing software on your NMT using just your mouse: NMT Community Software Installer
Visit this user's website Find all posts by this user
05-22-2009, 11:00 AM
Post: #1070
RE: [CSI] *** PUBLIC *** Community Software Installer 2.1.5 (Windows/Linux/OSX)
I still have mono-2.2. I will try though. The user who brought it up had this problem:

Code:
Unhandled Exception: System.TypeInitializationException: An exception was thrown by the type initializer for System.Windows.Forms.WindowsFormsSynchronizationContext ---> System.TypeInitializationException: An exception was thrown by the type initializer for System.Windows.Forms.ThemeEngine ---> System.TypeInitializationException: An exception was thrown by the type initializer for System.Windows.Forms.ThemeWin32Classic ---> System.TypeInitializationException: An exception was thrown by the type initializer for System.Drawing.KnownColors ---> System.TypeInitializationException: An exception was thrown by the type initializer for System.Drawing.GDIPlus ---> System.DllNotFoundException: /Library/Frameworks/Mono.framework/Versions/2.2/lib/libgdiplus.dylib
  at (wrapper managed-to-native) System.Drawing.GDIPlus:GdiplusStartup (ulong&,System.Drawing.GdiplusStartupInput&,System.Drawing.GdiplusStartupOutput&)
  at System.Drawing.GDIPlus..cctor () [0x00000]
  --- End of inner exception stack trace ---

I believe said user installed mono-2.2
Visit this user's website Find all posts by this user
05-22-2009, 11:04 AM (This post was last modified: 05-22-2009 11:06 AM by Ger Teunis.)
Post: #1071
RE: [CSI] *** PUBLIC *** Community Software Installer 2.1.5 (Windows/Linux/OSX)
(05-22-2009 11:00 AM)lundman Wrote:  I still have mono-2.2. I will try though. The user who brought it up had this problem:

I believe said user installed mono-2.2

Hmm that's an exception in GDI+ it seems, can't do much there. I'd advice him to update to a newer version of Mono. Mono 2.2 has lots of other problems as well, that is why CSI should not be used with mono 2.2.

On my ubuntu 9.10 using Mono 2.0.1 the CSI works okay.

Easy way of installing software on your NMT using just your mouse: NMT Community Software Installer
Visit this user's website Find all posts by this user
05-22-2009, 11:37 AM
Post: #1072
RE: [CSI] *** PUBLIC *** Community Software Installer 2.1.5 (Windows/Linux/OSX)
System.DllNotFoundException: /Library/Frameworks/Mono.framework/Versions/2.2/lib/libgdiplus.dylib

there are hits on this for osx mono, so seems they know of it too.
Visit this user's website Find all posts by this user
05-22-2009, 11:42 AM (This post was last modified: 05-22-2009 12:00 PM by Ger Teunis.)
Post: #1073
RE: [CSI] *** PUBLIC *** Community Software Installer 2.1.5 (Windows/Linux/OSX)
(05-22-2009 11:37 AM)lundman Wrote:  System.DllNotFoundException: /Library/Frameworks/Mono.framework/Versions/2.2/lib/libgdiplus.dylib

there are hits on this for osx mono, so seems they know of it too.

Could you check with mon 2.4?
(05-22-2009 11:42 AM)Ger Teunis Wrote:  Could you check with mon 2.4?

Somebody suggested the following regarding the libgdiplus exception:

Code:
Appears as though a symlink is missing in 2.4_4 that's required for
libgdiplus.dylib. Creating this symlink fixed the problem:

libglib-2.0.0.1800.1.dylib -> libglib-2.0.0.dylib

Easy way of installing software on your NMT using just your mouse: NMT Community Software Installer
Visit this user's website Find all posts by this user
05-22-2009, 08:07 PM
Post: #1074
RE: [CSI] *** UPDATED *** Community Software Installer 2.1.0 (Windows/Linux/OSX)
(05-21-2009 07:13 AM)Ger Teunis Wrote:  They will only be enabled on installed applications of course, you cannot stop an non-installed application Smile

You said you can't install anything, please download the Portable edition and post the content of ErrorLog.csv here (in code tags. the hash button when you create the post) after the installation error occurs again.

I retried with 2.1.5 and it seems to let me install stuff now...

Huh
Find all posts by this user
05-23-2009, 12:52 AM (This post was last modified: 05-26-2009 04:26 PM by ricocarlos.)
Post: #1075
RE: [CSI] *** UPDATED **** Community Software Installer 2.1.0 (Windows/Linux/OSX)
mvpmcx2 isn't working for me. I already installed gbpvr on my system, and have a network share to mvpmc on pch. If I go to it from the network share it works. It just won't work from the web service...

(05-16-2009 06:29 PM)Ger Teunis Wrote:  Mvpmcx2 finally got added
This great interface to GB-PVR media center software got added.
Excellent work on the client emveepee!

Use the webservice link to start the user interface (first real native interface!)
Power button (red button on remote) to close it again and go back to normal screen.
Find all posts by this user
05-23-2009, 07:28 AM
Post: #1076
RE: [CSI] *** UPDATED **** Community Software Installer 2.1.0 (Windows/Linux/OSX)
(05-23-2009 12:52 AM)ricocarlos Wrote:  mvpmcx2 isn't working for me. I already installed gbpvr on my system, and have a network share to mvpmc on pch. If I go to it from the network share it works. It just won't work from the web service...

Please give more info. You are able to start mvpmc from webservices but then it won't connect?

Easy way of installing software on your NMT using just your mouse: NMT Community Software Installer
Visit this user's website Find all posts by this user
05-24-2009, 09:10 AM
Post: #1077
Screensaver lost
I install my software through the great CSI application.

I have noticed my screensaver is not working anymore. I get a message the request can not be found. I do not know when the problem first occured.

Is it possible to restore the screensaver?

Thanx!
Find all posts by this user
05-24-2009, 10:09 AM (This post was last modified: 05-24-2009 10:10 AM by Ger Teunis.)
Post: #1078
RE: Screensaver lost
(05-24-2009 09:10 AM)slingshot Wrote:  I install my software through the great CSI application.
I have noticed my screensaver is not working anymore. I get a message the request can not be found. I do not know when the problem first occured.
Is it possible to restore the screensaver?

Not really a CSI issue. Create a new topic for that.
Did you try uninstalling the theme?

Easy way of installing software on your NMT using just your mouse: NMT Community Software Installer
Visit this user's website Find all posts by this user
05-24-2009, 10:27 AM
Post: #1079
RE: Screensaver lost
(05-24-2009 10:09 AM)Ger Teunis Wrote:  Not really a CSI issue. Create a new topic for that.
Did you try uninstalling the theme?

No I did not I believe. Can I just install a theme ?
Find all posts by this user
05-24-2009, 10:35 AM
Post: #1080
RE: Screensaver lost
(05-24-2009 10:27 AM)slingshot Wrote:  No I did not I believe. Can I just install a theme ?

If you didn't install another theme or uninstalling a theme doesn't work. Try a restart of NMT. If that doesn't work as well: create another topic for this in the correct sub forum.

This topic is meant for CSI and installation with CSI discussion only. Not for general problems, trying to keep it on topic. Sorry Smile

Easy way of installing software on your NMT using just your mouse: NMT Community Software Installer
Visit this user's website Find all posts by this user
Thread Closed 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
Star [CSI] Community Software Installer 2.7.2 ** UPDATED DEC 28th ** Ger Teunis 624 341,474 04-10-2014 05:52 AM
Last Post: jhmiller
  Support thread for HeartWare's PopCorn MKV Chapter Maker HeartWare 72 54,738 01-01-2012 10:10 AM
Last Post: halfelite
  Another Youtube thread - sorry mrmrmrmr 4 3,001 06-23-2010 08:27 PM
Last Post: mrmrmrmr
  Loss internal drive when using community inst.. tunafish 0 1,766 03-11-2010 01:20 PM
Last Post: tunafish
  A Plea To Software Developers jhmiller 0 1,644 01-04-2010 04:32 PM
Last Post: jhmiller
  Automounting from external html (+ISOs) - no software mod required. ?? (eg YAMJ skin) lordy 11 3,633 10-14-2009 10:31 PM
Last Post: lordy
  nmt community software installer on osx gabric098 24 12,670 10-04-2009 06:02 PM
Last Post: Ger Teunis
  What software can convert a BD rip to h.264 at 720p mrdenn1s 3 2,394 07-20-2009 10:36 AM
Last Post: mrdenn1s
  Software Installer Problems Ryu 3 2,510 07-06-2009 06:17 AM
Last Post: Ger Teunis
  cant start FTP on A110 after use of NMT Comunity sw installer bod 20 8,781 06-01-2009 04:48 PM
Last Post: Ger Teunis

Forum Jump: