Firmware: A-410 [01 Apr. 2014] | A-400 [12 Mar. 2014] | C-300 [13 Feb. 2014] | A-300 [24 Feb. 2014] | C-200 [11 July 2013] | A-200/A-210 [11 July 2013] | Popbox V8 [3 Dec 2013]

Just got your NMT | WIKI has the answers | Search the forum | Forum Rules/Policy | Firmware & Official NMT News | Popcornhour manuals



User(s) browsing this thread: 1 Guest(s)
Thread Closed 
YAMJ: robinsjexcal: highlited video display problem & maxing screen usage
01-07-2009, 05:27 AM
Post: #16
RE: YAMJ: robinsjexcal: highlited video display problem & maxing screen usage
the main table is set to be 1090 pixels wide.

theres also a 10 pixel padding to the right. To be honest i don't recall why we used that size, but to go more then 7x2 you're gonna have to try making the main table wider because its not gonna fit 8.

I just looked and the default skin uses 1090, and i guess thats where we got it from.


to change it you need to edit the table.main in the exportitem_index.css file.
Find all posts by this user
01-07-2009, 08:00 PM
Post: #17
RE: YAMJ: robinsjexcal: highlited video display problem & maxing screen usage
OK, so I made the table.main 1244 (1 cover + 2 padding) and created a new output from scratch (just in case) -- but it still failed. I did, however, notice a few things that may be noteworthy:

Even though I only increased the size of table.main, the genre table looked off-center and was slightly to the right. Also, when I went to the 8th (right-most) movie on each row and hit the "right arrow" button each time, everything would move over slightly -- hitting it 4 times would make things centered perfectly with all covers displayed and the genre table in the center, but moving right again, or going in any other direction would mess it up. I also experimented with the PCH's output resolution. If I set it to 720p, the 8 covers get slightly cut-off at the ends (by a very small bit), and when I'm on 1080p output there's a bit of space to spare using 8 covers (only a few pixels).

Because of the off-centered genres table and the ability to move over to the right, I believe that for some reason the PCH doesn't display the entire page with according to the set output resolution's width (likely to save precessing power). On 720p, the width should be 1280, and on 1080p it should be (I think) 1690 and that's been far from the case, but either way it's no good. Also, when the table.main overall width is increased the PCH seems to grow the entire Index "page width" to an out-of-bounds value relating to the displayed "screen-width" it sets. It could be possible it only does this when it's past a certain value, or it could just scale the page width according to it's contents -- but either way, the page is set too wide. That could be why the original table.main width was set to 1090 and if so, my plans have been derailed Sad .
Find all posts by this user
01-07-2009, 08:57 PM (This post was last modified: 01-07-2009 08:58 PM by excal.)
Post: #18
RE: YAMJ: robinsjexcal: highlited video display problem & maxing screen usage
Well a few things

1: I shoulda been a little more clear in the begining...i'm all for having as many covers as possible on the screen. I tried 8x2 initially but couldn't get it to work. Which is why i went back to 7x2

2: I think you may have discovered this already...but. The pch outputs a html file in 720p regardless of waht your tv setting is. You can tell this because even if you resize the table if you set a 1920x1080 fanart as your page background it won't fit on the screen.

3: Interestingly, a 1280x720 background doesn't display perfectly on the screen...it gets stretched. I forget what exactly the perfect sized image is to display...i can go back and find it if need be. But its smaller then 1280x720...but doesn't fill the whole screen.
Find all posts by this user
01-07-2009, 11:30 PM (This post was last modified: 01-07-2009 11:32 PM by sexyclient.)
Post: #19
RE: YAMJ: robinsjexcal: highlited video display problem & maxing screen usage
OOOOH, I see. Thanks again for all the help. Dang, this is pretty disheartening - but I've come too far to quit! I've got some ideas I want to try - like putting a giant table that's aligned to the left (so that it touches the left-most edge of the screen) and setting that table's width to the absolute width the PCH displays, and then putting the main and genre tables inside of there (so that it will stay centered according to what the PCH is displaying, rather than being centered relative to the width including the off-screen sections). If my theory is true, that should solve the problem (if indeed this is the cause) of the PCH displaying the index's width to be beyond that of the actual displayable area - and that's all assuming that the PCH shows the left-most edges (something I'm going to test out by making a 1280x720 pic in paint and drawing lines connected by the edges and seeing of they touch the edges of the screen).

I know I've bothered you a lot, but again I really appreciate you helping me to this extent - so I'm going to try and see if I can make it work myself. I'll post my results after I'm done experimenting.
Find all posts by this user
01-07-2009, 11:50 PM
Post: #20
RE: YAMJ: robinsjexcal: highlited video display problem & maxing screen usage
Its no bother, i'm actually quite interested in seeing the results of your test.


Another thing to note...I believe an image will act completely differently on the PCH set as a background then it will if its just set as an img src="" on the html page.

I'd be interested to see just how different based on the test you're setting up.

Would you mind trying that out in your tests? Use the exact same image...just do a test with it as background="" in the body tag, and one just as a img src="" somewhere on the html page.
Find all posts by this user
01-08-2009, 12:46 AM
Post: #21
RE: YAMJ: robinsjexcal: highlited video display problem & maxing screen usage
No problem, I've just got to learn to work my way around GIMP photo editor, then I'll post results.
Find all posts by this user
01-08-2009, 04:34 AM
Post: #22
RE: YAMJ: robinsjexcal: highlited video display problem & maxing screen usage
hi,

excuse me for a while on a different inquiry.
just want to inquire if we change to 6X2. do we to overwrite the html files once yamj is re-run? i hope 6X2 will prevent my screen from "moving" during selection of thumbnails and other options.

thanks.
Find all posts by this user
01-08-2009, 05:06 AM (This post was last modified: 01-08-2009 07:52 PM by sexyclient.)
Post: #23
RE: YAMJ: robinsjexcal: highlited video display problem & maxing screen usage
(01-08-2009 04:34 AM)qqbbbpp Wrote:  ...overwrite the html files once yamj is re-run?...
I think so. Sorry I can't give a more definite (lol, the word d-e-f-i-n-i-t-e is censored?) answer, but I just realized that I've always had the option turned on every time I've rescanned.

On another note, I ran a few tests and after lots of frustration finally realized I was using improper syntax a lot of the times (I used src="/picfile" instead of src="picfile"), but here's what I got:

I made a 1280x720 photo with a big X, the ends of which touched the corners, and used it as the background. Surprisingly enough, it fit perfectly (There's a 1 pixel dot all the way at the exact edges and they were visable!) on 1080p. When I switched to 720p output, the image was cropped - I forgot about all the other edges (I'm pretty tired & frustrated now, but I'll run more tests tomorrow), but it chopped off parts of the top of the image. The upper-left x moved from the corner slightly to the top of the screen, and because it's a 6pixel wide line, that means it moved at least 3 pixels down. I think I can safely say this is PCH behavior, because the PCH doesn't change the resolution of the TV itself (it stays at whatever output you set in the options and changes the way it displays images, I guess).

I put this image (in the others_all.html file, not the index.htm itself) right where the thumbnail posters usually display, and it was moved over to the right and down (my guess is it's moved just around double the distance to the right than it's moved down), and the rest moved offscreen. When I tried to put it in the index.htm file, it didn't even display the error - but by this time I was just too exhausted to continue tonight, so I'll do a more comprehensive set of experiments tomorrow. I'll update then.

UPDATE -- I just got back to the experimenting, and found some crappy results Sad . I managed to get the image up on the index page but the PCH didn't display it at the absolute left of the screen. Instead, it adds a (relatively) big gap to the left (leaving the starting point at what appears to be the same spot the covers are placed using 7x2 layout), and also slightly less than that to the top. This is so frustrating, I'm going to try to devise a workaround - maybe look to see if you can define coordinates in html or anything... I want 8x2 and I'm going to get it *growl*.
Find all posts by this user
01-08-2009, 10:02 PM
Post: #24
RE: YAMJ: robinsjexcal: highlited video display problem & maxing screen usage
heres that thread i was talking about... it has some info you might find usefull.

http://www.networkedmediatank.com/showth...437&page=1
Find all posts by this user
01-09-2009, 03:27 AM
Post: #25
RE: YAMJ: robinsjexcal: highlited video display problem & maxing screen usage
Ouch Sad . Fixing the blocky backgrounds was going to be my next project (as I thought they were just too big), but it looks like that road also leads to a dead end. Once I get my new library set up and running, I'm going to see if I can find some cool html hacks that work on the PCH -- google is now my last hope.
Find all posts by this user
01-09-2009, 03:43 AM
Post: #26
RE: YAMJ: robinsjexcal: highlited video display problem & maxing screen usage
ya, syabas is intending to look into the background blockiness...but they don't have an answer yet.
Find all posts by this user
Thread Closed 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Some movies doesn't start under yamj yeri60 0 128 04-18-2014 07:25 PM
Last Post: yeri60
  [YAMJ] Yamj Ubuntu gertvo 5 298 04-18-2014 12:23 PM
Last Post: gertvo
  YAMJ throws repeditive Java seg fault on linux (debian) mithrilG60 11 502 04-16-2014 09:31 AM
Last Post: Omertron
  FilmWeb problem ,scrape problem ???? cofik 1 232 04-15-2014 11:20 AM
Last Post: cofik
  YAMJ/Eversion: Customer Groups/Categories Adam1v 3 553 04-04-2014 09:30 AM
Last Post: Bazrah
  YAMJ not making any fanart for movies or tv shows simonmullan 15 4,852 04-02-2014 12:19 AM
Last Post: De1Phi4n
  [YAMJ] evZap/eversion Can't create Sets XML file for index Peterkocic 0 610 03-30-2014 11:06 AM
Last Post: Peterkocic
  YAMJ on A200 and A400 davlet 0 320 03-29-2014 07:18 PM
Last Post: davlet
  YAMJ HTML wrong Italian characters in PLOT and name cyberbob 1 436 03-27-2014 09:47 AM
Last Post: Omertron
  YAMJ (eversion+evhell) not seeing data say170 16 862 03-25-2014 10:52 AM
Last Post: Omertron

Forum Jump: