Firmware: A-410 [01 Apr. 2014] | A-400 [12 Mar. 2014] | C-300 [13 Feb. 2014] | A-300 [24 Feb. 2014] | C-200 [11 July 2013] | A-200/A-210 [11 July 2013] | Popbox V8 [3 Dec 2013]

Just got your NMT | WIKI has the answers | Search the forum | Forum Rules/Policy | Firmware & Official NMT News | Popcornhour manuals



User(s) browsing this thread: 1 Guest(s)
Thread Closed 
\\PCH-A110\share mapping EXTREMLY slow, or doesn't work at all
01-16-2009, 01:12 PM
Post: #1
\\PCH-A110\share mapping EXTREMLY slow, or doesn't work at all
Hi,

I'm wondering if anybody else is experiencing the same issue (I know at least one who is)

When trying to map \share on my A110 (simply entering \\192.168.0.100\share to My Computer address bar) It takes about 5 minutes until I either got an error message or credentials challenge. (happens on all PCs and laptops I tried)

I also tried to do it in cmd to have better control of the things:
C:\Documents and Settings\lacyk>net use P: \\192.168.0.100\share * /user:nmt
Type the password for \\192.168.0.100\share:
...5 minutes of waiting.....
System error 64 has occurred.

The specified network name is no longer available.

However, if I issue netstat after that (or after 'My Computer' way), I get:
Proto Local Address Foreign Address State
....
TCP lacyk1:2486 192.168.0.100:microsoft-ds ESTABLISHED

Any other attempt with other username ends up with error message 'resource is already mapped with diferent username'

I thought it might be the same thread as the following: http://www.networkedmediatank.com/showth...?tid=12447 - that points to the faulty mainboard at the end.

However, the difference is that I CAN map smb://192.168.0.100/share locally on PCH and can browse the content.

FTP works fine all the time, connection from PCH out to external shares (smb: ) works also fine.

Any ideas?

Thanks
Find all posts by this user
01-16-2009, 09:32 PM
Post: #2
RE: \\PCH-A110\share mapping EXTREMLY slow, or doesn't work at all
You can try a direct connection and see if you get the same poor performance. If the cable is good and you get better performance, you probably have something else in the network environment that contributes to this behaviour.

Audio, video, disco - I hear, I see, I learn.
Wiki. Wiki? Wiki!
Find all posts by this user
01-17-2009, 11:05 AM (This post was last modified: 01-17-2009 11:05 AM by Telexen.)
Post: #3
RE: \\PCH-A110\share mapping EXTREMLY slow, or doesn't work at all
Try reading through this thread which pertains to the DNS settings on the NMT. It's helped me to actually get connected slightly quicker, but it has not helped the transfer speed at all.

Be prepared for more people to claim it's your network...it's the "in" thing to do around here. You would think they would know better when this forum is filled with people with the same problem.

Good luck, I'm looking for a solution too.
Find all posts by this user
[+] 1 user says Thank You to Telexen for this post
01-18-2009, 02:50 PM
Post: #4
RE: \\PCH-A110\share mapping EXTREMLY slow, or doesn't work at all
Hi dc11ab,

Why do you believe the problem might be in a cable? Performance on FTP is 4 MB/s what seems to be ok. smb: mapping from PCH to other PC takes 30 seconds - what is acceptable at MS products Wink

But at the same time mapping from PC to \\IP_address\share works very slow. Please note I'm using the IP address instead of DNS. I don't see PCH on a local workgroup, but I don't deal with that now. First I'm trying to get it working on IP address.

Time-to-time it happens that I connect, but browsing through the directory tree is also extremly slow (1 minute delay for each click). Once I start copy - performance is fine.

Now when I'm writting this it came to my mind - couldn't be the case that Samba server on PCH srongly relies on DNS when talking back to samba client even if I'm using IP addresses? Seems like there is some timeout waiting for DNS. Is there any workarround on PCH?

Lacyk
Find all posts by this user
01-18-2009, 02:58 PM
Post: #5
RE: \\PCH-A110\share mapping EXTREMLY slow, or doesn't work at all
I did not suggest that the error was in the cable, I assumed that YOU already had verified that Wink

The point of my suggested exercise was to establish if there is a problem in the network environment between your PC host and the NMT, e.g some setting in your router, the DNS, a switch, MTU values etc.

With a direct connection you'd use static IP and get another environment compared to your normal setup, which is good for troubleshooting. If you want to try or not, that's up to you. I'm merely offering suggestions.

Audio, video, disco - I hear, I see, I learn.
Wiki. Wiki? Wiki!
Find all posts by this user
01-18-2009, 11:06 PM
Post: #6
RE: \\PCH-A110\share mapping EXTREMLY slow, or doesn't work at all
(01-18-2009 02:58 PM)dc11ab Wrote:  I did not suggest that the error was in the cable, I assumed that YOU already had verified that Wink

The point of my suggested exercise was to establish if there is a problem in the network environment between your PC host and the NMT, e.g some setting in your router, the DNS, a switch, MTU values etc.

With a direct connection you'd use static IP and get another environment compared to your normal setup, which is good for troubleshooting. If you want to try or not, that's up to you. I'm merely offering suggestions.

I did direct crossover cable connection and it wasn't working at all. I was not able to map neither \\PCH_IPaddress\share nor to map laptop's \movies share from Popcorn and nor even local smb:\\192.168.0.100\share from Popcorn itself.

However - during static IP addresing I also set Primary DNS to 192.168.0.1 - my D-Link. Before it was set to ISP's DNS. After cabling everything back to D-Link (still on static IP and DNS server settings) I was able to map \share on Popcorn. I used CLI command:
net use P: \\192.168.0.100\share * /user:nmt
and after 30-60 sec I've got mesage "command successfully completed"

When browsing P: in Windows Explorer, the responses are fast, playback of .avi files directly from share is smooth.

It's too late this evening to continue troubleshooting, but I plan to get Cisco switch, setup SPAN and use ethereal to check what's really going on. I'm not very familiar with SMB protocol, but I can let you know where I see delay in TCP session.

Lacyk
Find all posts by this user
[+] 1 user says Thank You to Lacyk for this post
01-22-2009, 11:45 PM
Post: #7
RE: \\PCH-A110\share mapping EXTREMLY slow, or doesn't work at all
ok guys,

I did a wireshark capture.

If moderator is interested I can provide it - it is very interesting.
I found two major issues:

1. once I try to map share on PCH's IP address, PCH starts to query all known DNS servers to resolve its own hostname!!! i.e PCH sends DNS query saying "what is IP address associated to host PCH-A110?" Could anybody explain why it is doing so??

Public (ISP) DNS server replies immediately by "no such host", D-Link doesn't reply at all and PCH is waiting 10 seconds before next attempt. It tries to resolve host names 6 times = 6x10 = 60 seconds delay - many people are experiencing exactly this delay.

2. I analyzed working and non-working SMB communication pattern. Both are identical at the beginning. When the working one autenticate itself with nmt/1234, PCH sends SMB message "SUCCESS" and then accepts client's tree browse requests..

Non-working establishes connection the same way, but after getting credentials and confirming them, it send to client TCP[RST,ACK] packet, that causes immediate session termination. Can anybody explain that?

Lacyk
Find all posts by this user
01-23-2009, 08:23 AM (This post was last modified: 01-24-2009 05:27 AM by pchuser.)
Post: #8
RE: \\PCH-A110\share mapping EXTREMLY slow, or doesn't work at all
That's taking the bull by the horns. It's nice to have a few users like that on any forum. Anyway, you might want to keep in mind that networking is handled differently in the upcoming firmware (just released for the A-100). I couldn't connect to my XP Home shares at all using August and October '08 firmwares (I've had to use June '08). However, the most recent (Jan '09) firmware sees my XP Home simple shares.
Find all posts by this user
01-23-2009, 12:49 PM
Post: #9
RE: \\PCH-A110\share mapping EXTREMLY slow, or doesn't work at all
(01-22-2009 11:45 PM)Lacyk Wrote:  I did a wireshark capture.

If moderator is interested I can provide it - it is very interesting.
(...)

Interesting finds, but why delimit the details to mods on this forum? We are users and owners just like everyone else here! More eyes is better! Wink

Don't know the size of the log file, but if it isn't too big, you could probably paste contents at pastebin.com, pastie.org or similar service and then link it here.

Did you use static IP or DHCP settings on your NMT when trying this?

Audio, video, disco - I hear, I see, I learn.
Wiki. Wiki? Wiki!
Find all posts by this user
01-23-2009, 06:04 PM
Post: #10
RE: \\PCH-A110\share mapping EXTREMLY slow, or doesn't work at all
(01-23-2009 12:49 PM)dc11ab Wrote:  Don't know the size of the log file, but if it isn't too big, you could probably paste contents at pastebin.com, pastie.org or similar service and then link it here.

Good idea Smile
here it is: http://rapidshare.com/files/188274266/PC...s.xls.html

I have also capture logs (*.pcap files), but there are too many useless details (like spanning tree packets, CDP status, Netbios broadcasts etc...). Here I did a summary with exact timestamps.

As I said, I'm not very familiar with SMB protocol so I don't know if the message sequence is good or not. This is just how it looks like when it works and when it dousn't work.

(01-23-2009 12:49 PM)dc11ab Wrote:  Did you use static IP or DHCP settings on your NMT when trying this?

In this case I used static settings, but I simply used the settings as they were assigned before by DHCP. I also did a DHCP reservation, so no IP confict could appear.


Any idea when can be new A110 firmware available?
Find all posts by this user
[+] 1 user says Thank You to Lacyk for this post
01-23-2009, 08:26 PM
Post: #11
RE: \\PCH-A110\share mapping EXTREMLY slow, or doesn't work at all
Just my 2 cents: I was having exactly the same issues with my A-100 and they got solved two days ago when I installed the new firmware just released. So I think the next update for A-110 should fix it for you too. However, thanks for the analysis, I think I understand why I was having problems (having a D-Link router) and my friend with another brand was ok.
Find all posts by this user
01-23-2009, 11:23 PM (This post was last modified: 01-23-2009 11:24 PM by ggr2005.)
Post: #12
RE: \\PCH-A110\share mapping EXTREMLY slow, or doesn't work at all
Thanks for your work LacyK

Ive just recieved a HDX1000 NMT 3 days ago and have been tearing my hair out trying to figure out why SMB browsing was so slow and buggy.
The DHCP server in my router (Belkin) assigns 2 DNS addresses to clients, the router address 192.168.2.1 and an ISP one.
When setting up a static address on my NMT i used both DNS addresses.
I'll try removing the ISP address and see if this helps.
Like you, I think the SAMBA server on the NMT is faulty. If I switch the NMT off, all other devices in the workgroup are found immediately, including a QNAP NAS.
Find all posts by this user
01-24-2009, 04:32 PM
Post: #13
RE: \\PCH-A110\share mapping EXTREMLY slow, or doesn't work at all
vaidyasr over at the following thread

http://www.networkedmediatank.com/showth...?tid=15618

has fixed this issue by adding an entry for the local NMT host to /etc/hosts.
Saves the NMT from querying DNS and slowing things down.
Result- much faster response when browsing the SMB workgroup.
Find all posts by this user
[+] 1 user says Thank You to ggr2005 for this post
01-27-2009, 12:49 AM
Post: #14
RE: \\PCH-A110\share mapping EXTREMLY slow, or doesn't work at all
I knew it might be good idea to provide a capture, so other people can investigate further. Smile

Actually I felt somehow, that entry in /etc/hosts might solve a problem, but I had no idea how to create it. Now I do. Thank you guys, this really works. Share mapping is now unbelievably fast.

L.
Find all posts by this user
Thread Closed 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  [BUG] A-400 Network share access pruthisith 1 148 04-16-2014 06:03 AM
Last Post: Willem53
  HELP A-200 hanging when opening nfs share folder spediegunz 19 469 04-15-2014 06:07 AM
Last Post: spediegunz
  NFS share a-200 Espensodal 1 213 04-06-2014 09:42 AM
Last Post: RXP
  A410 - Constant Share Issues Grimpy 2 339 03-25-2014 09:57 AM
Last Post: chris57
  PCH-A110 Mounting network drives on startup Karel 1 444 03-06-2014 11:29 PM
Last Post: Karel
  networkmounter for PCH-A110? CharlesDuBois 1 265 03-06-2014 11:23 PM
Last Post: CharlesDuBois
  Constant Problem "Share no longer Exists" tristar71 7 619 02-24-2014 07:07 AM
Last Post: Willem53
  share 1 folder want to remove bzb 2 536 02-08-2014 07:55 PM
Last Post: bzb
  Synology shares fail, Qnap shares work fine Searcher1 3 678 02-06-2014 07:56 AM
Last Post: Willem53
  Mount multiple shares to one share ZeeRuX 2 589 01-27-2014 03:08 PM
Last Post: ZeeRuX

Forum Jump: