Firmware: A-410 [01 Apr. 2014] | A-400 [12 Mar. 2014] | C-300 [13 Feb. 2014] | A-300 [24 Feb. 2014] | C-200 [11 July 2013] | A-200/A-210 [11 July 2013] | Popbox V8 [3 Dec 2013]

Just got your NMT | WIKI has the answers | Search the forum | Forum Rules/Policy | Firmware & Official NMT News | Popcornhour manuals



User(s) browsing this thread: 1 Guest(s)
Thread Closed 
PCH FTP username and password help
03-24-2008, 10:18 AM
Post: #1
PCH FTP username and password help
I absolutely cannot log on to this damned PCH with FTP.

I have updated to the newest firmware and applications offered and I get a 530 authentication error using username - ftpuser password - 1234

Just to be thorough I have tried username - ftpuser password - ftpuser. This is still a no-go.

I did a full reset to defaults, same issue.

I have tried filezilla, ncftp (linux), firefox, windows command line ftp and disabled passive mode on the FTP clients that allowed it. I have also tried setting a new password and it accepts it on the PCH config screen....but I still get a 530 authentication error when I try and connect from a client machine.

Any suggestions would be greatly appreciated.

Sam
Find all posts by this user
03-24-2008, 10:22 AM
Post: #2
 
what adress do you connect to? Just to be sure that you not being forwarded to another computer on your network that also has port 21 open.
Find all posts by this user
03-24-2008, 10:36 AM
Post: #3
 
I am connecting directly to the address that is set as a persistent IP from my FreeBSD router box. The PCH shows the IP and it is in agreement with what I set to be assigned in dhcpd based on the MAC address.

For what it's worth, SMB works without a hitch. I also tried getting to it with SMB by directly typing \\192.168.101.110 (the PCH IP) rather than just browsing the network by name and it is most definitely getting to the PCH that way.

Oh, and I also appear to have that strange bug where it fully boots up only after several tries in a row. Most of the time I get the initial screen, then black and nothing. If I get lucky it fully boots after several attempts by pulling out the power plug and plugging it back in.
Find all posts by this user
03-24-2008, 10:38 AM
Post: #4
 
Can you reach the PCHftp from your External IP? Ensure that port (21) are forwarded properly from your router/firwall
Find all posts by this user
03-24-2008, 10:49 AM
Post: #5
 
onofus Wrote:Can you reach the PCHftp from your External IP? Ensure that port (21) are forwarded properly from your router/firwall
On my external (WAN) side I have only one single port forwarded in and that is for OpenVPN. I typically tunnel in to my LAN at home to remote control machines and remotely map SMB shares, but no other ports are open at all to the outside world.

When I attempt to log on to the PCH it appears that the daemon is Pure-FTPd, is this correct? I have worked with PureFTPd in the past using the non-sql based setup, so....is there a way to get a shell on this thing and have a looksee?

pure-pw useradd -u 'user' -g 'group' -d 'chroot path'
then run pure-pw mkdb

This way I should be able to setup whatever I want it to be....? *sigh*

Bah....I think the next step will be to try reformatting that drive after getting my stuff off and then reinstalling the NMT applications.
Find all posts by this user
03-24-2008, 10:57 AM
Post: #6
 
PureFTP is correct, what i know of.

This is log from my connection directly to my internal ip.

----STATUS:> [2008-03-24 11:05:28] Getting listing ""...
STATUS:> [2008-03-24 11:05:28] Connecting to FTP server... 192.168.1.5:21 (ip = 192.168.1.5)...
STATUS:> [2008-03-24 11:05:28] Socket connected. Waiting for welcome message...
[2008-03-24 11:05:28] 220---------- Welcome to Pure-FTPd ----------
220-You are user number 1 of 10 allowed.
220-Local time is now 11:05. Server port: 21.
220 You will be disconnected after 1440 minutes of inactivity.
STATUS:> [2008-03-24 11:05:28] Connected. Authenticating...
COMMAND:> [2008-03-24 11:05:28] USER ftpuser
[2008-03-24 11:05:28] 331 User ftpuser OK. Password required
COMMAND:> [2008-03-24 11:05:28] PASS *****
[2008-03-24 11:05:28] 230-This server supports FXP transfers
230 OK. Current directory is /
STATUS:> [2008-03-24 11:05:28] Login successful.
COMMAND:> [2008-03-24 11:05:28] PWD
[2008-03-24 11:05:28] 257 "/" is your current location
STATUS:> [2008-03-24 11:05:28] Home directory: /
COMMAND:> [2008-03-24 11:05:28] FEAT
----
Find all posts by this user
03-24-2008, 08:08 PM
Post: #7
 
Here's my fix.

The PCH would not let me do a clean format on the HDD, it kept saying 'no new version available'. I pulled the drive out, put it in a pc, deleted all partitions and then I was able to do a clean install on the PCH. After doing this FTP was working; bug?
Find all posts by this user
Thread Closed 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  samba invalid username or password kostaspap 15 709 03-31-2014 11:45 PM
Last Post: kostaspap
  I forgot my password samba mustafa_dem 3 617 01-03-2014 04:58 PM
Last Post: Willem53
Lightning A400 can not connect to the windows home server without password xufei798 0 651 11-03-2013 06:40 AM
Last Post: xufei798
  network browser username and password pahurley 22 1,652 10-25-2013 12:50 PM
Last Post: jluc2808
  Password protect the Web UI on port 8088??? kalma 5 820 10-22-2013 02:23 PM
Last Post: kalma
  A300 - How to reset NMT password? Emporio72 1 974 10-10-2013 04:54 PM
Last Post: chris57
  Password change after update Jeroen4444 0 443 10-01-2013 11:34 AM
Last Post: Jeroen4444
  [A-210] User & Password for NFS: please help! virkom 2 1,396 09-16-2013 02:34 PM
Last Post: elche99
  A-210 changed ftp password, how can I change it again without the last? notim 4 1,295 05-15-2013 04:03 PM
Last Post: hetfield
  How to use Samba without a password ajamesg 4 1,548 05-13-2013 06:52 PM
Last Post: henryleelee0326

Forum Jump: