Firmware: A-410 [01 Apr. 2014] | A-400 [12 Mar. 2014] | C-300 [13 Feb. 2014] | A-300 [24 Feb. 2014] | C-200 [11 July 2013] | A-200/A-210 [11 July 2013] | Popbox V8 [3 Dec 2013]

Just got your NMT | WIKI has the answers | Search the forum | Forum Rules/Policy | Firmware & Official NMT News | Popcornhour manuals



User(s) browsing this thread: 1 Guest(s)
Post Reply 
[200/300] [Apps] QtWebKit - Web Browser - Updated 23rd Sep
01-29-2011, 11:24 PM
Post: #226
RE: [Apps] QtWebKit - Web Browser - C200/A200 - Updated 23rd Sep
(01-29-2011 04:30 AM)vaidyasr Wrote:  updated the nmt8 in page 1. That was a typo Sad

Browser is working really fine in my C200 with the same installation from ipkg. I'll analyze whether any issue with the packaging of browser.
Can you please do a run a simple below command and let me know the results?.

# cd /share/Apps/local/bin
# ldd browser


ok, I performed the command (remote from my PC) and the result is:

sh-3.00#
sh-3.00# ldd browser
libiconv.so.2 => /nmt/apps/lib/libiconv.so.2 (0x2aad8000)
libglib-2.0.so.0 => /usr/local/lib/libglib-2.0.so.0 (0x2abc8000)
libgthread-2.0.so.0 => /usr/local/lib/libgthread-2.0.so.0 (0x2ad48000)
libQtWebKit.so.4 => /usr/local/lib/libQtWebKit.so.4 (0x2ad60000)
libQtGui.so.4 => /usr/local/lib/libQtGui.so.4 (0x2c1b8000)
libQtNetwork.so.4 => /usr/local/lib/libQtNetwork.so.4 (0x2ce5c000)
libQtCore.so.4 => /usr/local/lib/libQtCore.so.4 (0x2cfe0000)
libpthread.so.0 => /lib/libpthread.so.0 (0x2d390000)
libstdc++.so.6 => /lib/libstdc++.so.6 (0x2d3bc000)
libm.so.6 => /lib/libm.so.6 (0x2d4c8000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x2d554000)
libc.so.6 => /lib/libc.so.6 (0x2d58c000)
librt.so.1 => /lib/librt.so.1 (0x2d6f0000)
libsqlite3.so.0 => /opt/syb/app/lib/libsqlite3.so.0 (0x2d708000)
libphonon.so.4 => /usr/local/lib/libphonon.so.4 (0x2d7cc000)
libQtDBus.so.4 => /usr/local/lib/libQtDBus.so.4 (0x2d848000)
libQtXml.so.4 => /usr/local/lib/libQtXml.so.4 (0x2d8fc000)
libpng12.so.0 => /opt/syb/sigma/lib/libpng12.so.0 (0x2d964000)
libz.so.1 => /opt/syb/sigma/lib/libz.so.1 (0x2d998000)
libfreetype.so.6 => /opt/syb/sigma/lib/libfreetype.so.6 (0x2d9bc000)
libdl.so.2 => /lib/libdl.so.2 (0x2da48000)
/lib/ld.so.1 (0x2aaa8000)
sh-3.00#
Find all posts by this user
Add Thank You Quote this message in a reply
01-30-2011, 09:07 PM
Post: #227
RE: [Apps] QtWebKit - Web Browser - C200/A200 - Updated 23rd Sep
I'm new to the C200 and would gladly contribute to get a web browser working if I could get it installed.
I don't know where to start.

What is CSI?

What is I-pkg? I downloaded and have 'ipkg.tar' but do not know how to install.

There is no /share/Apps folder

Can you give instructions on how to set it up starting with a new C200
Find all posts by this user
Add Thank You Quote this message in a reply
01-30-2011, 09:44 PM
Post: #228
RE: [Apps] QtWebKit - Web Browser - C200/A200 - Updated 23rd Sep
Download CSI here, run it on your PC and install I-pkg with it. When done, open http://nmt-ip:9999/local_web/ in your browser (replace nmt-ip with the ip-adress of your NMT), update the list of packages there and finally install the package called "browser". That's it.

Media Player: Popcorn Hour C-200 (with Samsung SpinPoint HM500JI, Lite-On iHOS104-37 and Alpha WMP-ND02 WLAN-Module)
TV: Grundig Vivance 32 LXW 82-6710 REF
Receiver: Topfield 5000 PVRt (with 160 GB HD)
Sound: LG FB162-DOU
NAS: Netgear ReadyNAS NVX RNDX400E
Find all posts by this user
Add Thank You Quote this message in a reply
02-01-2011, 01:58 AM
Post: #229
RE: [Apps] QtWebKit - Web Browser - C200/A200 - Updated 23rd Sep
(01-30-2011 09:44 PM)-Coco- Wrote:  Download CSI here, run it on your PC and install I-pkg with it. When done, open http://nmt-ip:9999/local_web/ in your browser (replace nmt-ip with the ip-adress of your NMT), update the list of packages there and finally install the package called "browser". That's it.

I can't find anything named I-pkg in CSI. I emptied the repository directory and re-launched, Still no I-pkg.
I down loaded I-pkg and tried Install from File with CSI and get
404 Not FoundRequested file not exist! (404 Not Found)
I get the same message trying to install other CSI Applications.
(Filemanager, c200remote)
Find all posts by this user
Add Thank You Quote this message in a reply
02-01-2011, 02:57 AM
Post: #230
RE: [Apps] QtWebKit - Web Browser - C200/A200 - Updated 23rd Sep
(01-29-2011 11:24 PM)botcha Wrote:  ok, I performed the command (remote from my PC) and the result is:

sh-3.00#
sh-3.00# ldd browser
libiconv.so.2 => /nmt/apps/lib/libiconv.so.2 (0x2aad8000)
libglib-2.0.so.0 => /usr/local/lib/libglib-2.0.so.0 (0x2abc8000)
libgthread-2.0.so.0 => /usr/local/lib/libgthread-2.0.so.0 (0x2ad48000)
libQtWebKit.so.4 => /usr/local/lib/libQtWebKit.so.4 (0x2ad60000)
libQtGui.so.4 => /usr/local/lib/libQtGui.so.4 (0x2c1b8000)
libQtNetwork.so.4 => /usr/local/lib/libQtNetwork.so.4 (0x2ce5c000)
libQtCore.so.4 => /usr/local/lib/libQtCore.so.4 (0x2cfe0000)
libpthread.so.0 => /lib/libpthread.so.0 (0x2d390000)
libstdc++.so.6 => /lib/libstdc++.so.6 (0x2d3bc000)
libm.so.6 => /lib/libm.so.6 (0x2d4c8000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x2d554000)
libc.so.6 => /lib/libc.so.6 (0x2d58c000)
librt.so.1 => /lib/librt.so.1 (0x2d6f0000)
libsqlite3.so.0 => /opt/syb/app/lib/libsqlite3.so.0 (0x2d708000)
libphonon.so.4 => /usr/local/lib/libphonon.so.4 (0x2d7cc000)
libQtDBus.so.4 => /usr/local/lib/libQtDBus.so.4 (0x2d848000)
libQtXml.so.4 => /usr/local/lib/libQtXml.so.4 (0x2d8fc000)
libpng12.so.0 => /opt/syb/sigma/lib/libpng12.so.0 (0x2d964000)
libz.so.1 => /opt/syb/sigma/lib/libz.so.1 (0x2d998000)
libfreetype.so.6 => /opt/syb/sigma/lib/libfreetype.so.6 (0x2d9bc000)
libdl.so.2 => /lib/libdl.so.2 (0x2da48000)
/lib/ld.so.1 (0x2aaa8000)
sh-3.00#
Do the below commands in telnet window and let me know the results.

# /etc/init.d/S50syb_framework stop
# cd /share/Apps/local/bin
# ./browser -qws -display directfb
(you will get lot of messages)

To start again the GUI again
# /etc/init.d/S50syb_framework start

Sriram
C200/A400/RPi - Onkyo HT-S3400 - LG 47LV3730

oPKG Available Packages and Info:
400 Series - 200/300 Series - 100 Series
Find all posts by this user
Add Thank You Quote this message in a reply
02-02-2011, 04:33 PM
Post: #231
RE: [Apps] QtWebKit - Web Browser - C200/A200 - Updated 23rd Sep
Not work
Find all posts by this user
Add Thank You Quote this message in a reply
02-02-2011, 04:36 PM
Post: #232
RE: [Apps] QtWebKit - Web Browser - C200/A200 - Updated 23rd Sep
(02-02-2011 04:33 PM)lofas7777 Wrote:  Not work

Could you elaborate on that, please. What does not work, in what context?

Audio, video, disco - I hear, I see, I learn.
Wiki. Wiki? Wiki!
Find all posts by this user
Add Thank You Quote this message in a reply
02-02-2011, 04:54 PM
Post: #233
RE: [Apps] QtWebKit - Web Browser - C200/A200 - Updated 23rd Sep
Web Browser does not work
Find all posts by this user
Add Thank You Quote this message in a reply
02-02-2011, 04:59 PM
Post: #234
RE: [Apps] QtWebKit - Web Browser - C200/A200 - Updated 23rd Sep
(02-02-2011 04:54 PM)lofas7777 Wrote:  Web Browser does not work

That's a cool feedback Smile Just kidding.

Sriram
C200/A400/RPi - Onkyo HT-S3400 - LG 47LV3730

oPKG Available Packages and Info:
400 Series - 200/300 Series - 100 Series
Find all posts by this user
Add Thank You Quote this message in a reply
02-03-2011, 06:22 AM
Post: #235
RE: [Apps] QtWebKit - Web Browser - C200/A200 - Updated 23rd Sep
Install nmt9 from ipkg and it will fix the qt-based applications startup via webservices.

Sriram
C200/A400/RPi - Onkyo HT-S3400 - LG 47LV3730

oPKG Available Packages and Info:
400 Series - 200/300 Series - 100 Series
Find all posts by this user
Add Thank You Quote this message in a reply
02-03-2011, 10:24 AM
Post: #236
RE: [Apps] QtWebKit - Web Browser - C200/A200 - Updated 23rd Sep
Alright, I can confirm that the browser works now. I've updated I-pkg to nmt9, updated the package list and installed the browser with ipkg install browser. It can now be run from the webservices.

However, there are a few drawbacks:
  • The browser is quite unstable and tends to freeze or crash when loading a webpage. Sometimes I was able to open 3 or 4 sites before that happened, but I also had it on the first page I tried.
  • My mouse doesn'work with it. I got a wireless mouse and keyboard, both connected via the same usb radio receiver. The keyboard works, the mouse doesn't.
  • Without mouse, the possibilities in the browser are very limited:
    - The tab key on the keyboard can be used to jump from link to link (shift+tab for jumping backwards doesn't work).
    - Return will open a link.
    - Pressing tab often enough will bring you to the address bar on top, so you can enter an address.
    - Cursor keys will scroll the content up/down and left/right.
    - Space will issue a page down.
    - The minus sign "-" will open a search box to search in the current page.
    - The arrows on the remote will scroll the page as well.
    - The return function on the remote will let you go back in the browser history.
    That's it.
  • The following is not possible, as far as I can see:
    - Maximising the window.
    - Moving the window.
    - Using menu options (e.g. Bookmarks, etc.): Alt+b doesn't work, F10 doesn't work. Sad
    - F11 won't switch into fullscreen view.
    - The current browser tab can't be closed (neither Ctrl+F4 nor Ctrl+W works).
    - No new tab can be opened.
    - No possibility to navigate forward in browser history (i.e. Alt+cursor left/right doesn't work).
    - But worst of all: No chance to leave the browser! I tried: Back on the remote, Source on the remote, Eject on the remote, Ctrl+backspace on the keyboard, Alt+F4 on the keyboard, Ctrl+Alt+delete on the keyboard. Nothing worked, so the only option is to hard-reset the NMT. Sad

Conclusion: The browser currently works, but is unstable and very limited in terms of usage possibitlities.

Media Player: Popcorn Hour C-200 (with Samsung SpinPoint HM500JI, Lite-On iHOS104-37 and Alpha WMP-ND02 WLAN-Module)
TV: Grundig Vivance 32 LXW 82-6710 REF
Receiver: Topfield 5000 PVRt (with 160 GB HD)
Sound: LG FB162-DOU
NAS: Netgear ReadyNAS NVX RNDX400E
Find all posts by this user
Add Thank You Quote this message in a reply
02-03-2011, 08:00 PM
Post: #237
RE: [Apps] QtWebKit - Web Browser - C200/A200 - Updated 23rd Sep
(02-03-2011 10:24 AM)-Coco- Wrote:  Conclusion: The browser currently works, but is unstable and very limited in terms of usage possibitlities.

Good review. Couldn't agree more Sad Unfortunately...
Find all posts by this user
Add Thank You Quote this message in a reply
02-04-2011, 03:32 AM
Post: #238
RE: [Apps] QtWebKit - Web Browser - C200/A200 - Updated 23rd Sep
(02-03-2011 10:24 AM)-Coco- Wrote:  [*]My mouse doesn'work with it. I got a wireless mouse and keyboard, both connected via the same usb radio receiver. The keyboard works, the mouse doesn't.

The issue was with your mouse model only. Once you have inserted the mouse, you can see the system log via dmesg command. I am using dell mouse and it works fine.

Sriram
C200/A400/RPi - Onkyo HT-S3400 - LG 47LV3730

oPKG Available Packages and Info:
400 Series - 200/300 Series - 100 Series
Find all posts by this user
Add Thank You Quote this message in a reply
02-04-2011, 11:10 AM
Post: #239
RE: [Apps] QtWebKit - Web Browser - C200/A200 - Updated 23rd Sep
Too bad. Sad I'll try some other mice then and will report back.

Media Player: Popcorn Hour C-200 (with Samsung SpinPoint HM500JI, Lite-On iHOS104-37 and Alpha WMP-ND02 WLAN-Module)
TV: Grundig Vivance 32 LXW 82-6710 REF
Receiver: Topfield 5000 PVRt (with 160 GB HD)
Sound: LG FB162-DOU
NAS: Netgear ReadyNAS NVX RNDX400E
Find all posts by this user
Add Thank You Quote this message in a reply
02-04-2011, 02:11 PM
Post: #240
RE: [Apps] QtWebKit - Web Browser - C200/A200 - Updated 23rd Sep
My mouse DELL doesn'work with it
Find all posts by this user
Add Thank You Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  [100/200/300/400] Music Player Daemon (MPD) - v0.18.5 - Updated on 10th Dec 2013 - CSI vaidyasr 562 226,655 Yesterday 12:35 PM
Last Post: vaidyasr
Video [200/300/400] [Apps] PchTrakt 0.4.23 - Trakt.tv, Betaseries and Last.fm scrobbling jhmiller 675 57,453 Yesterday 03:49 AM
Last Post: jhmiller
  [400] oPKG v0.2.0 - Updated on 30th Jan 2014 - CSI vaidyasr 236 31,969 04-09-2014 09:02 PM
Last Post: Adelscott
  [200/300] oPKG v0.2.0 - Updated on 30th Jan 2014 - CSI vaidyasr 505 238,055 04-03-2014 12:34 AM
Last Post: vaidyasr
  [100/200/300/400] Community Software Installer 2.7.4.0 ** UPDATED MAR 18th 2013** jhmiller 506 123,237 03-28-2014 11:40 PM
Last Post: Bogey
  [100/200/300/400] aMule v2.3.1 - Updated 7th Oct 2010 - CSI vaidyasr 149 53,996 02-14-2014 06:11 AM
Last Post: drh104
Brick [200] [Apps] pyLoad 0.4.3, a fast, lightweight and full featured download manager global_nmt 50 23,408 02-07-2014 10:03 AM
Last Post: psydea
Star [100/200/300/400] Download Manager v3.2 Released - Updated 10th Apr 2009 - CSI vaidyasr 1,701 707,777 01-19-2014 06:47 PM
Last Post: calbo
  [200/300/400] MKVTools v1.1.1 - Updated 27th Feb 2010 - CSI vaidyasr 46 19,063 01-04-2014 06:27 PM
Last Post: pencitku
  [100/200/300/400] autostart CSI apps - how to fix after FW update ? tutenchamun 0 491 12-27-2013 02:08 AM
Last Post: tutenchamun

Forum Jump: