Firmware: A-410 [01 Apr. 2014] | A-400 [12 Mar. 2014] | C-300 [13 Feb. 2014] | A-300 [24 Feb. 2014] | C-200 [11 July 2013] | A-200/A-210 [11 July 2013] | Popbox V8 [3 Dec 2013]

Just got your NMT | WIKI has the answers | Search the forum | Forum Rules/Policy | Firmware & Official NMT News | Popcornhour manuals



User(s) browsing this thread: 1 Guest(s)
Thread Closed 
Cannot browse SMB or view SMB shares directly
02-20-2010, 08:33 PM
Post: #1
Cannot browse SMB or view SMB shares directly
I have an A-100 and I've been having this problem off and on for probably about a year and finally decided to try and figure it out. My network is laid out with the PCH and a couple other computers (Win7 now, but same issue when they were XP & Vista) on a router (running DD-WRT). Very often, if I click on the "Network Browser" option under "Media Sources" the PCH will show the spinning icon for a longer-than-usual amount of time and finally only show me an option for browsing NFS shares.

Now, every now and then the Network Browser will actually work and quickly pop up an option for SMB shares and everything works from there. I've searched around multiple times and never found a solution... I tried setting everything from this page http://www.networkedmediatank.com/wiki/i...p/Windows7 but it didn't help. It seems to be a network-wide issue since I can't browse *any* SMB shares at all.

Also, I tried typing in a direct share name in the format smb://pcname/sharename and it did not work either.

Any help would be greatly appreciated!
Find all posts by this user
02-20-2010, 11:28 PM
Post: #2
RE: Cannot browse SMB or view SMB shares directly
Today I had same issue - twice. Always after uninstalling something throught CSI installer from my A-200. I went to maintenance menu choose manufacturer settings and power off. After 2 hours I power on and I was able to browse the network throught SAMBA - strange. The second issue was almost the same, but here I made a deep clean in CSI installer, new nmt apps install and I manually set up the network and shares. Now is all working like before. I see SAMBA network and not just NFS.
Find all posts by this user
02-26-2010, 12:06 PM
Post: #3
RE: Cannot browse SMB or view SMB shares directly
On set up screen is it "10/100" or "Auto" for ethernet configuration?

If so, double check your ethernet cable and router If they are really connected well and then restart your PC and Popcorn and try o click "My Network Places" under PC Start menu or whatever it is. Check out If you can see a network apart from your own PC like "PCH" or something? When you see that that means connection is ok.

Popcorn C-200 Owner
EMM (Ember Media Manager) Settings Here
Find all posts by this user
02-26-2010, 12:34 PM (This post was last modified: 02-26-2010 12:34 PM by spawn.)
Post: #4
RE: Cannot browse SMB or view SMB shares directly
Quote:and finally only show me an option for browsing NFS shares

Whenever the option to browse the "Workgroup" are missing and oly "NFS Servers" are available for browsing then there is a master browser issue on the network

When the option to browse "Workgroup" are missing, its because whichever PC on the network that has the role as master browser are turned off. In a network environment one PC has the role of being master browser, this keeps information about all the units on the network in a browse list and informs every unit about the list. If this specific computer are tuned off then no units on the network will be able to browse the list and see each other (even if you can still ping them) untill a new unit on the network has been promoted to be browse master and updated a new browse list. There are constantly an election for browse master role being performed, so that if none are found a new will automatically be elected.

So in case the workgroup are missing from the browse option because the previous browse master unit are turned off, then waiting a litle while for the next election and update to happen will automatically bring back the option.

To have a more stable operation, it is recommended to manually force a specific computer which is mostly turned on to be the browse master.

This is done with a reg.key

Code:
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Browser\Parameters]
"IsDomainMaster"="TRUE"
"MaintainServerList"="Auto"

Living room: C200/A200/A100 HDMI to Pioneer KURO KRP-500A plasma / Denon AVR 3808 / KEF 5005.2 / B&W DM685
Kids room: C200/A110 HDMI to Panasonic 42PZ85, Optical to Logitech Z5500.


PLEASE READ THE WIKI
Find all posts by this user
[+] 1 user says Thank You to spawn for this post
Thread Closed 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  PCH C-300 Network Browse and NFS not working Tenchy 5 796 02-12-2014 12:05 PM
Last Post: Tenchy
  Synology shares fail, Qnap shares work fine Searcher1 3 650 02-06-2014 07:56 AM
Last Post: Willem53
  PCH A400 can't browse in NFS subdirectories axel82 0 421 01-28-2014 09:52 PM
Last Post: axel82
  Mount multiple shares to one share ZeeRuX 2 581 01-27-2014 03:08 PM
Last Post: ZeeRuX
  NFS - Can browse, but can't play demon11c 12 972 12-03-2013 08:05 PM
Last Post: w00ter
  A-210 share browser ignores share names after 9 shares have been defined buffer80 2 696 11-19-2013 08:49 AM
Last Post: buffer80
  Need help setting up NFS shares on ubuntu!!! robo-chimp21 2 571 11-03-2013 10:29 AM
Last Post: robo-chimp21
  Need help configuring ubuntu file server for NFS shares to PCH A-300!! robo-chimp21 1 808 10-30-2013 01:24 PM
Last Post: chris57
  LAN network shares login pass not remembered diablo 1 1,436 09-22-2013 08:42 AM
Last Post: chris57
  connect directly to NAS without router george7523 5 3,624 07-21-2013 12:56 PM
Last Post: BanditRider

Forum Jump: