Firmware: A-410 [01 Apr. 2014] | A-400 [12 Mar. 2014] | C-300 [13 Feb. 2014] | A-300 [24 Feb. 2014] | C-200 [11 July 2013] | A-200/A-210 [11 July 2013] | Popbox V8 [3 Dec 2013]

Just got your NMT | WIKI has the answers | Search the forum | Forum Rules/Policy | Firmware & Official NMT News | Popcornhour manuals



User(s) browsing this thread: 1 Guest(s)
Thread Closed 
Windows7 pc blocks network browsing from PCH
09-21-2010, 01:05 PM
Post: #1
Windows7 pc blocks network browsing from PCH
Hello,

I''ve got a network consisting of a windows Xp desktop, Windows Xp laptop, Windows Vista home premium laptop and a Windows 7 Home Premium Desktop. Desktops are connected to the network wired and the laptops wireless. I've got a PCH-a110 and and emtec mediaplayer which are connected wired to the network. All pc's can see and access the popcorn and the emtec and can connect to each other.

Since the windows 7 pc is within the network I can not browse the network from my PCH and not from my emtec. The windows 7 pc can access the a110.
I've tried all the solutions mentioned in the wiki, but nothing seems to solve my problem. Anyone got a solution?
Find all posts by this user
09-21-2010, 02:41 PM
Post: #2
RE: Windows7 pc blocks network browsing from PCH
I have W7 x64 Enterprise on all of my PC's. In fact they were recently reinstalled from scratch.

Like you my direct links worked but I could not get anything via Network Browser.

I tried everything until finally I solved it. I did all of the options suggested and nothing worked until IO uninstalled Windows Live Sign-In or MSN Messenger. Then suddenyl all was well and I could see my shared folders and drives.

The mystery to me is that prior to the reinstall I was using W7 and had WLS installed. I had W7 x64 ultimate and not enterprise which I currently have, so either the W7 or WLS version must be the problem combination.

A400: SD Card(Apps), HDMI C200: USB(Apps), BD ROM (SH-B083L(SB01)), HDMI
CAT6 Wired Network: TV Panasonic TX-P42G20, HP ProCurve 1400-8G, Netgear GS-608/605, Synology CS407
Find all posts by this user
09-21-2010, 04:33 PM
Post: #3
RE: Windows7 pc blocks network browsing from PCH
Hi Chris,

Thanks for your reaction.
I already uninstalled windows live sign in on my xp and on my windows 7 pc.
But the a110 doesn't see shares on as well xp as on windows 7 pc's.
(But to my opinion the WLS can not be the cause of problems. I know my IT stuff, used to work as a Network Administrator, have my MCSA 2003 certificate). The strange thing is that my emtec S800 gets an IP address by but sinds the windows 7 pc is running it even can not access web radio.
It is windows 7 issue, but even in my 700 page windows 7 manual I can not find a solution.
My a110 does see one of my NAS disks, but thr is no multimedia stuff on that one.
Find all posts by this user
09-21-2010, 04:47 PM (This post was last modified: 09-21-2010 04:48 PM by chris57.)
Post: #4
RE: Windows7 pc blocks network browsing from PCH
Do your direct links work?
Have you a guest account enabled on your PC?
What settings are you using? Exactly the same as in the WIKI W7 page?

WLS is my issue, I have reinstalled a few versions of it as I really want it. Each time I install it blocks the network browser and each time I uninstall it I can then access through. Only on W7 is this an issue not XP.

If you are having problems with XP and also W7 then there's something in your network settings that's not right or your AV/Firewall software is blocking things. Can you access from the PC your NMT?
You do have the NMT Apps installed and the SMB server ON?

A400: SD Card(Apps), HDMI C200: USB(Apps), BD ROM (SH-B083L(SB01)), HDMI
CAT6 Wired Network: TV Panasonic TX-P42G20, HP ProCurve 1400-8G, Netgear GS-608/605, Synology CS407
Find all posts by this user
09-21-2010, 05:16 PM (This post was last modified: 09-21-2010 05:17 PM by johnpoz.)
Post: #5
RE: Windows7 pc blocks network browsing from PCH
And which device on the network is your master browser?

The PCH should prob be winning the election - but not sure with this emtec? Or you NAS..

So take a look -- which box on your network is the master browser? And is it staying that way or are you getting flipping between machines?

simple nbtstat -A to the IP in question will show you which machine is the master browser.

edit: As to your WLS issue
"Each time I install it blocks the network browser and each time I uninstall it I can then access through.

I have to say nonsense to this -- It has NOTHING to do with network browsing - NOTHING!! How would it be blocking it??
Find all posts by this user
09-21-2010, 07:40 PM (This post was last modified: 09-21-2010 08:50 PM by drummer40.)
Post: #6
RE: Windows7 pc blocks network browsing from PCH
Personally I thought it could be some problem with the master browser, remember some problems with Vista.
I found a small tool on the internet, how to determine the master browser on your workgroup with 1 mouseclick
See link below.
I'll update if I've solved the problem with the master browser.
http://scottiestech.info/2009/02/14/how-...workgroup/

Update:
I'm certain the problem is related to the master browser. I've I run the tool I found the samba servers (nas) which act as unix/linux machines all say they are master browser. I don't know how to stop the and make the windows 7 home premium machine the master browser
Find all posts by this user
09-21-2010, 10:09 PM (This post was last modified: 09-21-2010 10:10 PM by accident.)
Post: #7
RE: Windows7 pc blocks network browsing from PCH
On the windows 7 machine:

Control Panel - Administrative Tools - Local Security Policy
Local Policies - Security Options

Network security: LAN Manager authentication level
Send LM & NTLM responses

Minimum session security for NTLM SSP
Disable Require 128-bit encryption
also keep in mind that dependin gon the type of network you set the windows 7 machine for it may not even talk with the browsers.. so if your set to public, you need to also change your network setting to home
Find all posts by this user
09-21-2010, 10:20 PM (This post was last modified: 09-21-2010 10:23 PM by johnpoz.)
Post: #8
RE: Windows7 pc blocks network browsing from PCH
"all say they are master browser"

You mean there is more than one device on the same network that are saying they are the master browser? Or is this just ONE nas device?

Your going to have problems with more than 1 sure -- but does not really matter which device does it, could be your pch, could be your win7 machine, could be your nas - really does not matter. But there should only be 1 on the same network saying this.

If they are running samba, can you edit the samba config to tell them not too? Or change their OS Level so they win the election?

I would pick a device that is on all the time to be your master browser. PCH is a bitch to mess with the samba config to tell it not to be the master browser. So if you want something else to be it - its just easier to increase the OS Level so it wins - ie say 255 Wink

edit: its real easy to tell a windows machine not to be the master browser, just disable the computer browser service. Its not needed unless the box is going to be a master browser or backup browser, etc.
Find all posts by this user
09-21-2010, 10:45 PM
Post: #9
RE: Windows7 pc blocks network browsing from PCH
be default, older samba and newer windows machines aren't going to talk together even though it appears to be the same thing, they are using different auth and protocol versions.

Of course to make it even worse, things like personal firewall software might add another level of who is allowed to talk to who.. I know mcafee on my mini is a pain in the butt to get machine names to work
Find all posts by this user
09-21-2010, 11:08 PM
Post: #10
RE: Windows7 pc blocks network browsing from PCH
I shut down all 3 NAS which seem to run samba and the pch-a110 becomes master browser and the problem is solved.
But I need the 3 NAS, because most of my data, except the movies is on those disks.

Can anyone give me instructions or a link to a site how to configure the NAS not to become master browser and how to tell the a110 to be master browser.

Although it is a master browser problem, it happened after installing the windows 7 desktop. Something within Windows 7 is causing the samba servers to act strange, because before windows 7, I has no problems for years within the same network.
Find all posts by this user
09-21-2010, 11:09 PM (This post was last modified: 09-21-2010 11:15 PM by johnpoz.)
Post: #11
RE: Windows7 pc blocks network browsing from PCH
Yeah there can be some problem with older samba say 2 series in sharing files with newer windows -- but they have not changed how browsing works..

edit:
What specific nas? Do you have access to shell on them where you can edit the samba config?

Im grabbing a OLD copy of ubuntu to test old samba with I would think the 4.10 version had the old 2. series on it Smile Hmmm maybe not, seems 3.0 was release before that time frame even.. Hmmmm? Have to find something that runs the old samba to play with Wink
Find all posts by this user
09-21-2010, 11:14 PM
Post: #12
RE: Windows7 pc blocks network browsing from PCH
Yes they have, they've moved up to ntlm v2 in 7, 2008 and vail. 7 defaults to talk to v1 and v2 however depending on auth settings (or missing auth settings) it may not talk to v1 clients. I think that is what is happening here and theres a v1 "workgroup" and a v2 "workgroup" which may appear like most machines are the master browser. DroboFS for example runs a newer samba and they default to v2 only settings also.. I know the pch can only talk to v1 servers so if the win7 machine isn't talking to the v1 master browser than its not in the workground the pch is talking with.
Find all posts by this user
09-21-2010, 11:34 PM
Post: #13
RE: Windows7 pc blocks network browsing from PCH
hmmmm -- I don't have old samba to play with.. Maybe I can install on my wrt54g running dd-wrt?

but w7 using smb2.1 I do believe.

Anyhoo -- if win7 box is causing confusion for who is suppose to be the master browser between your pch and your nas's -- since you said it worked fine before win7.

Then just turn off the win7 computer browser service, set to disable - and he wont play in their elections. And I know the pch running as master browser can find win7 and 2k8 just fine.
Find all posts by this user
09-21-2010, 11:43 PM (This post was last modified: 09-21-2010 11:48 PM by chris57.)
Post: #14
RE: Windows7 pc blocks network browsing from PCH
(09-21-2010 05:16 PM)johnpoz Wrote:  edit: As to your WLS issue
"Each time I install it blocks the network browser and each time I uninstall it I can then access through.

I have to say nonsense to this -- It has NOTHING to do with network browsing - NOTHING!! How would it be blocking it??

Please tell me as you seem to know it all. I'm sure it's got to be a setting in W7 as well as I did have it working on W7 in my last install.

A forum member found this to be their cause of problems using the Network Browser and as stated so did I. I think they mentioned that it was first commented on in the WDTV forums, something to do with the port that is used from memory but not 100%.

Can't wait to get WLS working and get IM back for the kids. It'll save me some earache so shoot away please.

A400: SD Card(Apps), HDMI C200: USB(Apps), BD ROM (SH-B083L(SB01)), HDMI
CAT6 Wired Network: TV Panasonic TX-P42G20, HP ProCurve 1400-8G, Netgear GS-608/605, Synology CS407
Find all posts by this user
09-21-2010, 11:52 PM
Post: #15
RE: Windows7 pc blocks network browsing from PCH
I know mcafee has snuck in their firewall on everyone's install without asking if you want to install it.. it has this authenticate who can talk to who and it does it via dns/browser service.. you might want to see if theres similar software on your machines..

here's the mcafee kicker, you can't disable/uninstall it
Find all posts by this user
Thread Closed 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  [BUG] A-400 Network share access pruthisith 1 44 Today 06:03 AM
Last Post: Willem53
  PCH-A110 Mounting network drives on startup Karel 1 418 03-06-2014 11:29 PM
Last Post: Karel
  Network performance with new NAS EasyTiger 1 503 02-19-2014 06:53 AM
Last Post: Willem53
  PCH C-300 Network Browse and NFS not working Tenchy 5 786 02-12-2014 12:05 PM
Last Post: Tenchy
  Help - Network streaming best configuration ? Tass 0 573 02-10-2014 03:24 PM
Last Post: Tass
  Strange network problems ThrawnJl 11 862 02-08-2014 06:49 AM
Last Post: ThrawnJl
  network setup browser not working Drugsprofessor 22 1,512 01-27-2014 10:48 AM
Last Post: Drugsprofessor
  Network problem: Access denied and You don't have permission rajjejosefsson 18 1,843 01-25-2014 04:08 PM
Last Post: rajjejosefsson
  To network Ubuntu 13:10 Samba / NFS Retni 0 694 01-03-2014 09:09 AM
Last Post: Retni
  A-200 loses network connection on file transfer Dornoeth 8 5,161 01-02-2014 04:36 PM
Last Post: J i m s t e r

Forum Jump: