Firmware: A-410 [01 Apr. 2014] | A-400 [12 Mar. 2014] | C-300 [13 Feb. 2014] | A-300 [24 Feb. 2014] | C-200 [11 July 2013] | A-200/A-210 [11 July 2013] | Popbox V8 [3 Dec 2013]

Just got your NMT | WIKI has the answers | Search the forum | Forum Rules/Policy | Firmware & Official NMT News | Popcornhour manuals



User(s) browsing this thread: 1 Guest(s)
Post Reply 
Missing files / dirs with c200 as UPnP AV render
01-19-2011, 12:05 PM (This post was last modified: 01-19-2011 12:29 PM by TomdeAap.)
Post: #1
Missing files / dirs with c200 as UPnP AV render
I've just started using the C200 as a UPnP AV renderer. My main goal is to control music playback from my phone or perhaps future tablet Smile. I'm using 2 different Android Apps (EyeController and AndroMote Pro) to plug the music collection (stored on internal C200 HD) to th C200. And this works great.

However, not all files/artists/albums etc are listed. Some examples: I have a folder

/share/Music/Adele/19

In this folder the mp3's are listed when I look with Windows Explorer. However when I browse 'By Folder' with the remote apps to that path, I don't get further than

/share/Music/Adele

And it shows no music. When I browse 'By Album' or Artist, nothing shows up; no '19', no 'Adele' or whatever.

However, when I copied all files from /share/Music/Adele/19 to /share/Music/Adele, the files showed up. So I thought that it had to do with folders in folders, but the folder /share/Music/Anouk contains mp3s which still don't showup.

The weird thing is that when I go to the NMJ and search for Adele, nothing shows up. Are these two related in that they use the same DB to search media? Would it be possible to reset this DB?

(BTW, all mp3s are correctly tagged)

Cheers for any help!
Find all posts by this user
Add Thank You Quote this message in a reply
01-19-2011, 02:20 PM
Post: #2
RE: Missing files / dirs with c200 as UPnP AV render
The UPnP service does have it's own reference somewhere, but I can't remember exactly where from the top of my head.

As a workaround, I think the easiest way to reset it is to re-install NMT Apps (the 'Typical install' does not touch existing media files).

Audio, video, disco - I hear, I see, I learn.
Wiki. Wiki? Wiki!
Find all posts by this user
Add Thank You Quote this message in a reply
01-19-2011, 02:23 PM
Post: #3
RE: Missing files / dirs with c200 as UPnP AV render
(01-19-2011 02:20 PM)dc11ab Wrote:  The UPnP service does have it's own reference somewhere, but I can't remember exactly where from the top of my head.

As a workaround, I think the easiest way to reset it is to re-install NMT Apps (the 'Typical install' does not touch existing media files).

OK, will give that a go, cheers!
Find all posts by this user
Add Thank You Quote this message in a reply
01-28-2011, 10:52 AM
Post: #4
RE: Missing files / dirs with c200 as UPnP AV render
(01-19-2011 02:20 PM)dc11ab Wrote:  The UPnP service does have it's own reference somewhere, but I can't remember exactly where from the top of my head.

As a workaround, I think the easiest way to reset it is to re-install NMT Apps (the 'Typical install' does not touch existing media files).

I did 2 things; First i tried reinstalling the NMT apps, then I tried deleting and rebuilding the UPnP database following this thread. However, no luck; still a lot of songs are not displayed whether browsing by artist,album folder or whatever.

Any more ideas by anyone? Playing the songs that work makes me want this feature to work even more!
Find all posts by this user
Add Thank You Quote this message in a reply
07-24-2011, 06:41 PM
Post: #5
RE: Missing files / dirs with c200 as UPnP AV render
old thread kick.. did you solve it ?
On my setup it only shows Mp3 files if they are in the root of the "share" dir and and the file extention is in capitalism (i.e. MP3)
Find all posts by this user
Add Thank You Quote this message in a reply
07-28-2011, 08:21 AM
Post: #6
RE: Missing files / dirs with c200 as UPnP AV render
(07-24-2011 06:41 PM)IQzero Wrote:  old thread kick.. did you solve it ?
On my setup it only shows Mp3 files if they are in the root of the "share" dir and and the file extention is in capitalism (i.e. MP3)

Nope no luck... But I chose not to use it as an DLNA server any more, because the damn thing is VERY unreliable as such. Really a shame...
Find all posts by this user
Add Thank You Quote this message in a reply
07-28-2011, 08:17 PM
Post: #7
RE: Missing files / dirs with c200 as UPnP AV render
(01-28-2011 10:52 AM)TomdeAap Wrote:  
(01-19-2011 02:20 PM)dc11ab Wrote:  The UPnP service does have it's own reference somewhere, but I can't remember exactly where from the top of my head.

As a workaround, I think the easiest way to reset it is to re-install NMT Apps (the 'Typical install' does not touch existing media files).

I did 2 things; First i tried reinstalling the NMT apps, then I tried deleting and rebuilding the UPnP database following this thread. However, no luck; still a lot of songs are not displayed whether browsing by artist,album folder or whatever.

Any more ideas by anyone? Playing the songs that work makes me want this feature to work even more!

Hi,

You mentioned that you were able to delete and rebuild UPnP database. Is there a thread, which describes how to do it? I was not able to find it on the forum.

Do you have any idea, where is UPnP database stored? I would like to try to delete it ...

Regards,
Roman Flegar
Find all posts by this user
Add Thank You Quote this message in a reply
07-28-2011, 08:47 PM
Post: #8
RE: Missing files / dirs with c200 as UPnP AV render
Or wait till next version. the next firmware is getting a new UPNP stack.
Find all posts by this user
Add Thank You Quote this message in a reply
07-29-2011, 06:42 AM
Post: #9
RE: Missing files / dirs with c200 as UPnP AV render
(07-28-2011 08:17 PM)flegarr Wrote:  Do you have any idea, where is UPnP database stored? I would like to try to delete it ...

Regards,
Roman Flegar

Hmm can't seem te find it. However reinstalling NMT Apps (Typical) should have the same effect. But I'd wait for the new firmware I guess.
Find all posts by this user
Add Thank You Quote this message in a reply
07-29-2011, 06:48 AM
Post: #10
RE: Missing files / dirs with c200 as UPnP AV render
I think the path is
/nmt/apps/server/mscanner.db
Find all posts by this user
Add Thank You Quote this message in a reply
[+] 1 user says Thank You to halfelite for this post
12-29-2011, 09:46 PM
Post: #11
RE: Missing files / dirs with c200 as UPnP AV render
(07-29-2011 06:48 AM)halfelite Wrote:  I think the path is
/nmt/apps/server/mscanner.db

Thank you. The path is right and the problem was solved.

Regards,
Roman Flegar

PS.
Sorry for my late response ...
Find all posts by this user
Add Thank You Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Popcorn C-300 as UPNP renderer odysseus 1 1,331 02-10-2014 06:07 AM
Last Post: odysseus
  Workaround for flac playback under UPnP / DLNA gefst 0 1,462 09-15-2013 09:57 PM
Last Post: gefst
  Streaming from C-200 to LG HDTV via DLNA - uPNP TXPilot69 11 8,211 06-04-2013 03:40 PM
Last Post: miralda40
  uPnP Client issue with XBMC zigzag 0 1,670 03-20-2013 02:33 PM
Last Post: zigzag
  change mime types on default pch upnp server? AdamNJ 1 1,401 03-11-2013 07:32 AM
Last Post: halfelite
  llink UPNP won't stream krylon 3 1,920 02-14-2013 03:43 AM
Last Post: lundman
  How to het UPNP working on pch a210 Pierskw 3 2,893 01-11-2013 12:52 PM
Last Post: atticus
  Accessing Playon software on PCH C200 fails! cap2587 22 4,778 11-19-2012 07:24 PM
Last Post: cap2587
  Upnp server A200 + external HDD wizzy 0 1,569 11-12-2012 12:34 PM
Last Post: wizzy
  UPnp server for C200 blief 1 1,659 10-31-2012 06:53 AM
Last Post: halfelite

Forum Jump: