Firmware: A-410 [01 Apr. 2014] | A-400 [12 Mar. 2014] | C-300 [13 Feb. 2014] | A-300 [24 Feb. 2014] | C-200 [11 July 2013] | A-200/A-210 [11 July 2013] | Popbox V8 [3 Dec 2013]

Just got your NMT | WIKI has the answers | Search the forum | Forum Rules/Policy | Firmware & Official NMT News | Popcornhour manuals



User(s) browsing this thread: 1 Guest(s)
Post Reply 
C-200 Dead PSU - Just for the record
02-22-2011, 06:30 PM
Post: #17
RE: C-200 Dead PSU - Just for the record
(02-22-2011 12:49 PM)DeadHammer Wrote:  
(02-08-2011 04:26 PM)chris57 Wrote:  Strange as everyone using the PCH offical support on the forum has had a brand new PSU. You must be using a reseller, are you?

Not me.. Huh My (very little used) first batch, bought direct from Syabas, c-200's power supply (inevitably?) failed recently and I was told simply "Your serial number has expired we could not send you a free PSU. Please email sales@popcornhour.com for PSU pricing." Sales then pointed me to the standard sales web site where it will cost me $27 for the power supply and $35 for the shipping.Undecided

I, not only object to having to replace what was obviously a sub-standard component on a product that has had a very easy life, but to have to pay £38 (plus duty?) for a replacement adds insult to injury.

Fun while it lasted but - Dune HD Max here I come!..Smile

ps - Anyone in the UK know where I can get a PSU for a C-200 at a more reasonable cost? thanks in advance!Smile

If I find out, I will post the info.

C-200 1TB WD Green Internal, 1080p Panasonic 46" Plasma. Cat6 Wired, Procurve Layer 2 switched Gigabit, 8TB RAID5 SAS (sata) - Suse Linux 11.4.
Find all posts by this user
Add Thank You Quote this message in a reply
Post Reply 


Messages In This Thread
RE: C-200 Dead PSU - Just for the record - Slackness - 02-22-2011 06:30 PM
RE: C-200 Dead PSU ? - DaChow - 07-20-2011, 02:25 PM
RE: C-200 Dead PSU ? - chris57 - 07-20-2011, 03:38 PM
RE: C-200 Dead PSU ? - DrummerJitsu - 12-10-2011, 05:27 AM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Repair C200 dead PSU mike8333 240 110,448 04-12-2014 02:26 PM
Last Post: focax
  A-210 dead - possible electric problems wigyori 1 341 02-27-2014 06:36 AM
Last Post: Willem53
Sad C200 dead? Power LED flashing (only) + changes colour Roughrider 3 932 02-13-2014 03:35 PM
Last Post: Roughrider
  PSU Dead? mstrong 1 373 02-11-2014 05:59 AM
Last Post: halfelite
  C200 shows splash screen then goes dead gossamer 5 614 01-24-2014 07:37 PM
Last Post: gossamer
Shocked C200 dead after connecting Audio to component leanderv 3 462 01-08-2014 02:32 PM
Last Post: Willem53
  Internal drive dead - Can't get C-200 working well again WE9V 6 787 01-02-2014 11:58 PM
Last Post: WE9V
  C200 Completely Dead waynelod47 5 550 11-26-2013 03:23 PM
Last Post: BanditRider
  My A210 is dead xiaorui 0 431 10-08-2013 01:50 PM
Last Post: xiaorui
  no SMB Shares after dead PSU mayrmart 0 379 09-28-2013 05:42 PM
Last Post: mayrmart

Forum Jump: