Firmware: A-410 [01 Apr. 2014] | A-400 [12 Mar. 2014] | C-300 [13 Feb. 2014] | A-300 [24 Feb. 2014] | C-200 [11 July 2013] | A-200/A-210 [11 July 2013] | Popbox V8 [3 Dec 2013]

Just got your NMT | WIKI has the answers | Search the forum | Forum Rules/Policy | Firmware & Official NMT News | Popcornhour manuals



User(s) browsing this thread: 1 Guest(s)
Thread Closed 
c200 died, blinking (white/red) power button
02-14-2011, 06:55 PM
Post: #1
c200 died, blinking (white/red) power button
Tonight my C200 died, when I flick it on I only see the power button blinking between red and white.

What can I do? Has it really completely died?
Removing internal HDD didn't do a think either Sad

Easy way of installing software on your NMT using just your mouse: NMT Community Software Installer
Visit this user's website Find all posts by this user
02-14-2011, 08:00 PM
Post: #2
RE: c200 died, blinking (white/red) power button
From what I read that seems to indicate a PSU failure. But i'm not 100% possitive about that. Halfe or Chris would be better suited to answer you.

If it is a psu, the good news is they just posted them on the website for sale today. And they're pretty reasonably priced too.

Pannasonic Plasma 50" -->HK254-->Emotiva xpa-5 & upa-2
A100 w/ 500gb HDD, A200 w/ mn100, c200 w/ 2.5" 250gb
Calm 2.1, YAMJ - Redefined 1.8a skin, Music Jukebox 8
WHS ex490 w/ 2.5tb's
Find all posts by this user
02-14-2011, 08:06 PM
Post: #3
RE: c200 died, blinking (white/red) power button
Thanks for your tip. A common issue then 'cause they provide a replacement part online? Hmm. Perhaps I need to think abou this again.

Easy way of installing software on your NMT using just your mouse: NMT Community Software Installer
Visit this user's website Find all posts by this user
02-14-2011, 08:18 PM
Post: #4
RE: c200 died, blinking (white/red) power button
Take the lid off and listen when you turn it on, do you hear a clicking and are there LEDs on the motherboard that are flashing red/green aswell.

If you are an electronic geek you can find the replacement capacitors for little money and replace them. Otherwise its $62 including shipping to the UK:-
http://www.popcornhour.com/onlinestore/i...nItemId=24

If you are out of warranty replacements parts are cheap enough. A motherboard is $50, a PSU £27 there's no a lot else that can go wrong. It's not a case of hard luck you have to buy a new unit.

A400: SD Card(Apps), HDMI C200: USB(Apps), BD ROM (SH-B083L(SB01)), HDMI
CAT6 Wired Network: TV Panasonic TX-P42G20, HP ProCurve 1400-8G, Netgear GS-608/605, Synology CS407
Find all posts by this user
02-14-2011, 08:22 PM (This post was last modified: 02-14-2011 08:23 PM by nuke12.)
Post: #5
RE: c200 died, blinking (white/red) power button
A standard computer ATX PSU will work to test the problem. It won't fit of course but if the problem goes away then you know the issue. Any computer ATX PSU should work because they all have better power output then the requirements of the PCH.

C-200, A-110 both playing from a DIY Linux Raid 5 server.

Remuxes, Captures and Transcodes done on a desktop running;
Win7, Intel i7 hexacore processor with 24 GB ram, WD VR OS drive and a WD Black 2 TB data drive.
Find all posts by this user
02-14-2011, 08:23 PM
Post: #6
RE: c200 died, blinking (white/red) power button
Interesting, I hadn't even considered the mobo going bad.

So the clicking and flashing mobo lights will tell him whether its the mobo or the psu?

Pannasonic Plasma 50" -->HK254-->Emotiva xpa-5 & upa-2
A100 w/ 500gb HDD, A200 w/ mn100, c200 w/ 2.5" 250gb
Calm 2.1, YAMJ - Redefined 1.8a skin, Music Jukebox 8
WHS ex490 w/ 2.5tb's
Find all posts by this user
02-14-2011, 09:34 PM
Post: #7
RE: c200 died, blinking (white/red) power button
Yes, it happened to me last week.
First indications were media were freezing up during playback for up to 30 secs with no response from the remote.
Although pressing PowerOff on remote would eventually show the unit turn off (standby).
Another problem was that it was re-booting over and over again and a hard reboot (unplugged) was not working.
Find all posts by this user
02-14-2011, 10:58 PM
Post: #8
RE: c200 died, blinking (white/red) power button
popcorn hour now sales the power supply on there website same with all there remotes.
Find all posts by this user
02-14-2011, 11:08 PM
Post: #9
RE: c200 died, blinking (white/red) power button
I get a clicking noice and green/red flashing LEDs next to the reset button on the mobo. Does this mean my psi is dead? I hope it's the psu.

Easy way of installing software on your NMT using just your mouse: NMT Community Software Installer
Visit this user's website Find all posts by this user
02-14-2011, 11:09 PM
Post: #10
RE: c200 died, blinking (white/red) power button
(02-14-2011 11:08 PM)Ger Teunis Wrote:  I get a clicking noice and green/red flashing LEDs next to the reset button on the mobo. Does this mean my psi is dead? I hope it's the psu.

Nope its the psu. the clicking noise is the pcu and the green and red leds are because the pch is trying to start one led controls the power control Modula the other is the actual board led.
Find all posts by this user
02-14-2011, 11:14 PM
Post: #11
RE: c200 died, blinking (white/red) power button
So it's psu. Great. Contacting support right now. Thanks guys!

Easy way of installing software on your NMT using just your mouse: NMT Community Software Installer
Visit this user's website Find all posts by this user
02-15-2011, 03:54 AM
Post: #12
RE: c200 died, blinking (white/red) power button
You can try what i posted here

It worked for me until i received my replacement power supply so i was not 100% dead in the water.

PCH A-200 16GB USB -> HDMI -> Samsung LN46A650 | A200 -> Toslink -> Logitech Z-5500 (Harmony 700)
PCH C-200 8GB USB -> HDMI -> Sharp LC46D64U (Harmony 550)
Eversion Whisper eskin + WHS V1 (25TB Q6600/4GB RAM ) -> Mediasonic HR82-SU3S2 (Backup)
D-Link DNS 323 for sale
Find all posts by this user
02-21-2011, 10:54 AM
Post: #13
RE: c200 died, blinking (white/red) power button
Good news, after replacing the PSU my C200 works fine again.
Thanks guys!

Easy way of installing software on your NMT using just your mouse: NMT Community Software Installer
Visit this user's website Find all posts by this user
Thread Closed 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  C200 flickers on 1080P setting TreadWater 146 41,739 Yesterday 03:49 PM
Last Post: TReneR
  Repair C200 dead PSU mike8333 240 111,077 04-12-2014 02:26 PM
Last Post: focax
  DIY: build your own c200 'IR eye' for cheap linuxworks 80 77,920 04-12-2014 01:42 PM
Last Post: grizzly666
  PCH C200 freezes regularly laserblues2 5 495 03-26-2014 01:07 PM
Last Post: laserblues2
  SATA_DISK_A? loads veeery slow (C200) bosch 7 467 03-19-2014 02:45 PM
Last Post: Willem53
  Popcorn c200 not starting red flashing on motherboard saikonl 2 465 03-18-2014 02:46 PM
Last Post: saikonl
  C200 won't start using controller AnnonyMouse 5 415 03-17-2014 10:21 PM
Last Post: AnnonyMouse
  Lost confidence in PCH C200 Aquasport 36 2,324 03-02-2014 09:55 PM
Last Post: halfelite
  Replace PSU by normal atx power supply? RedHat 10 921 03-02-2014 12:38 AM
Last Post: aaronwt
  C200/Yamaha RX-A1010 issue lergei 6 599 02-20-2014 09:17 AM
Last Post: Willem53

Forum Jump: