Firmware: A-410 [01 Apr. 2014] | A-400 [12 Mar. 2014] | C-300 [13 Feb. 2014] | A-300 [24 Feb. 2014] | C-200 [11 July 2013] | A-200/A-210 [11 July 2013] | Popbox V8 [3 Dec 2013]

Just got your NMT | WIKI has the answers | Search the forum | Forum Rules/Policy | Firmware & Official NMT News | Popcornhour manuals



User(s) browsing this thread: 1 Guest(s)
Post Reply 
[subtitles] A-110 Chinese subtitles
08-25-2011, 12:54 PM (This post was last modified: 08-25-2011 01:06 PM by attehccuz.)
Post: #1
[subtitles] A-110 Chinese subtitles
Hello everybody,

I have som issues using the chinese subtitles on my PCH A110. I've read that the a110 supports the big5 subs (and maybe more) and everytime I tried to load them on a movie I just had strange caracters like $&ù etc etc.

Is there any way to read them alright? Or do I have to make a conversion before?

Thanks,
Find all posts by this user
Add Thank You Quote this message in a reply
08-25-2011, 03:48 PM
Post: #2
RE: [subtitles] A-110 Chinese subtitles
I use chinese subtitles but I always have to convert them to UTF-8. The way I do it as follows.

1) Open them in word which will automatically ask you to convert them and will display them properly.
2) Copy the whole file
3) Paste into a notepad document
4) Save as.....select Encoding=UTF-8
5) Save as moviename.srt

There may be an easier way but this works for me.
Find all posts by this user
Add Thank You Quote this message in a reply
08-25-2011, 03:49 PM
Post: #3
RE: [subtitles] A-110 Chinese subtitles
You have to set the encoding in subtitles to accept utf-8 (or big 5 or other chinese encoding depends on how the subtitles are encoded).

You can also remux the movie with subtitles to be encode with utf-8.

(08-25-2011 12:54 PM)attehccuz Wrote:  Hello everybody,

I have som issues using the chinese subtitles on my PCH A110. I've read that the a110 supports the big5 subs (and maybe more) and everytime I tried to load them on a movie I just had strange caracters like $&ù etc etc.

Is there any way to read them alright? Or do I have to make a conversion before?

Thanks,
Find all posts by this user
Add Thank You Quote this message in a reply
08-27-2011, 01:22 AM
Post: #4
RE: [subtitles] A-110 Chinese subtitles
ok so here is what I did:

Here is what the sub looks like when I open it with notepad:

Quote:1
00:01:17,900 --> 00:01:18,877
¿ªÊ¼Ðж¯,

3
00:01:33,750 --> 00:01:36,787
ħ¹íÆõÔ¼

4
00:03:26,070 --> 00:03:28,106
ÄãÊÇÐÂÀ´µÄDavis?

5
00:03:28,310 --> 00:03:31,507
²», Îҿɲ»ÕâôÈÏΪ, ÎÒÊÇÀ´°ïÄãÃÇͨ·µÄ.

I open it with Word, choose the chinese big5 encoding, and get this that I put on a notepad with UTF-8 subtitle:

Quote:嚜?
00:01:17,900 --> 00:01:18,877
聶穠?翹??繞簪,

3
00:01:33,750 --> 00:01:36,787
?禮繒穩?繭?翹

4
00:03:26,070 --> 00:03:28,106
?瓊?????織繕?Davis?

5
00:03:28,310 --> 00:03:31,507
簡罈, ??聶?簡罈?璽?織???穠, ?????織簞簿?瓊???穡?繚繕?.

Now on my PCH I can see the chinese ideograms perfect but why do I got so many "?"
Find all posts by this user
Add Thank You Quote this message in a reply
08-27-2011, 06:51 AM
Post: #5
RE: [subtitles] A-110 Chinese subtitles
I guess the quesitn is why do you have som many ? in notepad. Whatever shows up in notepad will show up on the PCH.
It seems like your file is still not correct but I have never had this problem so I dont have a godd suggestion.
Can you send me the link to the subtitle file and maybe I can try?
Find all posts by this user
Add Thank You Quote this message in a reply
08-27-2011, 04:10 PM
Post: #6
RE: [subtitles] A-110 Chinese subtitles
Hi,

I will first try the same procedure with other subtitles and see if the sub is wrong or not. If I still got my problem I will send it to you Smile

thanks
Find all posts by this user
Add Thank You Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  [SUBTITLE] SBS subtitles PCH-A110? iradu 7 4,143 10-31-2012 10:20 AM
Last Post: cosmos
  [Subtitles] not showing external srt when mkv has internal subs theone 3 3,404 06-18-2012 06:49 AM
Last Post: leighv
  [Subtitles] A-110, forced subtitles and mkv heathramos 0 1,738 05-12-2012 09:24 PM
Last Post: heathramos
  [SUBTITLE] Can I play *.sub subtitles on my PCH-A110? stone28 5 4,884 12-06-2011 09:44 AM
Last Post: stone28
  Please Help Subtitles Problem! swisstoni 5 3,398 09-27-2011 04:50 PM
Last Post: heathramos
Video [SUBTITLES] Hardcoded subs and missing characters berling 2 2,311 07-14-2011 05:21 PM
Last Post: berling
Car [SUBTITLE]Polish Subtitles how to display correctly? Racer16 5 4,826 07-11-2011 09:21 AM
Last Post: tradeitdamn
  Attaching subtitles to mkv file using mkvmerge unable to resolved issue?? Racer16 7 7,508 05-22-2011 06:29 AM
Last Post: Racer16
  [Subtitles] Subtitles as an external file won't play due to bad Encoding date Blurrz 7 3,772 03-03-2011 01:39 PM
Last Post: dsob
  Will A110 ever support PGS subtitles markus625 13 5,971 02-14-2011 12:30 PM
Last Post: de-mor

Forum Jump: