Firmware: A-410 [01 Apr. 2014] | A-400 [12 Mar. 2014] | C-300 [13 Feb. 2014] | A-300 [24 Feb. 2014] | C-200 [11 July 2013] | A-200/A-210 [11 July 2013] | Popbox V8 [3 Dec 2013]

Just got your NMT | WIKI has the answers | Search the forum | Forum Rules/Policy | Firmware & Official NMT News | Popcornhour manuals



User(s) browsing this thread: 1 Guest(s)
Post Reply 
Videos Not Playing [YAMJ/PCH A210/Macbook/NETWORK_SHARE/SYNOLOGY NAS]
09-02-2011, 11:29 AM (This post was last modified: 09-02-2011 12:02 PM by killer nads.)
Post: #1
Videos Not Playing [YAMJ/PCH A210/Macbook/NETWORK_SHARE/SYNOLOGY NAS]
Hi Guys,

Really need some urgent help with my YAMJ setup!

I think i have a path problem in library.xml but have tried every combination and still cant get a video to play! I am only trying to mount one NETWORK_SHARE

I have used the following guides for help and also searched everywhere for an answer but have not found a solution, so am really hoping some one can help me with this.

http://www.pettingers.org/code/yamj-multi.html#nfsonly

http://www.networkedmediatank.com/wiki/i..._NAS_setup

I can access my videos perfectly through the PCH interface when i do not install YAMJ.

But when i install YAMJ, i see the skin and indexes fine, but when i try to play a video - the screen does a brief flash and then goes back to the detail view it was one earlier! It as if it cant find the file!

My setup is: Popcorn hour A210, Macbook, Synology NAS Server. Connection type is NFS.

The sharename i have created on the PCH is: "NMJ NFS"
On the PCH the path is automatically showing as: "/volume1/multimedia"

When I mount the drives on my Mac, the drive i get is "multimedia", in this folder I have a Movies folder with sub directories for HD Movies, 3D Movies, TV Shows etc..

This is what my library xml paths look like:

[Library 1]
Code:
<path>/Volumes/multimedia/Movies/3D Movies/</path>

[Library 2]
Code:
<path>/Volumes/multimedia/Movies/HD Movies/</path>

etc...

These seem fine, as the terminal commands can find these files correctly and create there xml/html files in my jukebox.

I think the problem must be with my Network Player Paths:

[Library 1]
Code:
<playerpath>file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/NMJ NFS/multimedia/Movies/3D Movies/</playerpath>

[Library 2]
Code:
<playerpath>file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/NMJ NFS/multimedia/Movies/HD Movies/</playerpath>

I am pointing these paths to the correct corresponding sub directories where the files are located on my NAS Server!

Is anyone able to see the mistake I am making as I seemed to have tried every possible combination, even trying to include /volume1/ before /multimedia/ !!!

Also, when i use open the index.html on my web browser - should i be able to play the file on my Macbook through this? As I try to click on a tv episode to play but it just gives me a screen with the player path as shown above and saying not found!

Thanks alot guys, appreciate any help you can offer!
Find all posts by this user
Add Thank You Quote this message in a reply
09-02-2011, 12:00 PM
Post: #2
RE: Videos Not Playing [YAMJ/PCH A210/Macbook/NETWORK_SHARE/SYNOLOGY NAS]
You have said you created a share on the PCH as 'NFJ NFS' but your player path says 'NMJ NFS'

Is that just a typo in your post?

PCH C-200, PCH A-110, Onkyo TX-SR875, Toshiba 46XF355D, ReadyNAS NV+ 4TB, ReadyNas NV+ 6TB, Wired cat5e network.
Find all posts by this user
Add Thank You Quote this message in a reply
09-02-2011, 12:01 PM
Post: #3
RE: Videos Not Playing [YAMJ/PCH A210/Macbook/NETWORK_SHARE/SYNOLOGY NAS]
Yeah sorry its a typo should be: NMJ NFS
Find all posts by this user
Add Thank You Quote this message in a reply
09-02-2011, 12:05 PM (This post was last modified: 09-02-2011 12:12 PM by ConciseCarp.)
Post: #4
RE: Videos Not Playing [YAMJ/PCH A210/Macbook/NETWORK_SHARE/SYNOLOGY NAS]
I thought it probably was, but wanted to check anyway!

What folder do you end up in when you access the network share directly from the PCH? If you end up in the multimedia folder, just remove that from your playerpath.

PCH C-200, PCH A-110, Onkyo TX-SR875, Toshiba 46XF355D, ReadyNAS NV+ 4TB, ReadyNas NV+ 6TB, Wired cat5e network.
Find all posts by this user
Add Thank You Quote this message in a reply
09-02-2011, 12:30 PM
Post: #5
RE: Videos Not Playing [YAMJ/PCH A210/Macbook/NETWORK_SHARE/SYNOLOGY NAS]
Not sure if it's an issue or not, but I would suggest removing the space from your share name. Linux (PCH & NAS) doesn't really like spaces in things, so it might just help to remove that.

Otherwise your paths look correct.

Post up an example of the path from the XML of the movie and we might be able to see the issue.

Visit this user's website Find all posts by this user
Add Thank You Quote this message in a reply
09-02-2011, 01:02 PM (This post was last modified: 09-02-2011 01:05 PM by killer nads.)
Post: #6
RE: Videos Not Playing [YAMJ/PCH A210/Macbook/NETWORK_SHARE/SYNOLOGY NAS]
(09-02-2011 12:05 PM)ConciseCarp Wrote:  I thought it probably was, but wanted to check anyway!

What folder do you end up in when you access the network share directly from the PCH? If you end up in the multimedia folder, just remove that from your playerpath.

Im not 100% sure what you mean of how to access the network share directly from my PCH?!

But if you mean when I go to settings and do a browse to add a network share, i choose my NAS server and then in the path it shows:
volume1/multimedia

But I have no way of checking if this changes when i browse to another sub directory within my parent folder (ie. multimedia)!

I spent hours on this yesterday night and became very frustrated - almost wanted to throw the PCH out the window Big Grin (even though i knew it was an issue with paths rather then player itself!)

(09-02-2011 12:30 PM)Omertron Wrote:  Not sure if it's an issue or not, but I would suggest removing the space from your share name. Linux (PCH & NAS) doesn't really like spaces in things, so it might just help to remove that.

Otherwise your paths look correct.

Post up an example of the path from the XML of the movie and we might be able to see the issue.

Hi,

I will try removing the space this evening when i get home and give it another go! I will also post the path from XML!

But are we 100% sure that this path in the library.xml is correct:

Code:
<playerpath>file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/NMJ NFS/multimedia/Movies/3D Movies/</playerpath>

Obviously thats pointing to a specific folder within my root!

I wouldn't just need to point to the root would I? Like this:

Code:
<playerpath>file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/NMJ NFS/</playerpath>

thanks
Find all posts by this user
Add Thank You Quote this message in a reply
09-02-2011, 01:08 PM (This post was last modified: 09-02-2011 01:21 PM by ConciseCarp.)
Post: #7
RE: Videos Not Playing [YAMJ/PCH A210/Macbook/NETWORK_SHARE/SYNOLOGY NAS]
Sorry I wasn't clear. I just meant that if you access your network share on your PCH (the one you have added) what folder do you end up in. I had this issue when I was using network shares. My network share was set up one level further in the folders than my library path.

If you are in the multimedia folder when you click on your NMJ NFS share on your PCH, then you need to remove 'multimedia' from your library path.

To be honest, I don't think I've been much clearer there. Sorry!

Edit: Looking back at your post it says:

Quote:The sharename i have created on the PCH is: "NMJ NFS"
On the PCH the path is automatically showing as: "/volume1/multimedia"

I think this answers my question. When you access your network share it takes you directly to the multimedia folder where you will see your 'Movies' folder, so I'm pretty sure you just need to remove 'multimedia' from both your library playerpaths:

[Library 1]

Code:
<playerpath>file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/NMJ NFS/Movies/3D Movies/</playerpath>

[Library 2]

Code:
<playerpath>file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/NMJ NFS/Movies/HD Movies/</playerpath>

Then again I'm no expert, so I could be wrong!

PCH C-200, PCH A-110, Onkyo TX-SR875, Toshiba 46XF355D, ReadyNAS NV+ 4TB, ReadyNas NV+ 6TB, Wired cat5e network.
Find all posts by this user
Add Thank You Quote this message in a reply
09-02-2011, 01:17 PM
Post: #8
RE: Videos Not Playing [YAMJ/PCH A210/Macbook/NETWORK_SHARE/SYNOLOGY NAS]
(09-02-2011 01:08 PM)ConciseCarp Wrote:  Sorry I wasn't clear. I just meant that if you access your network share on your PCH (the one you have added) what folder do you end up in. I had this issue when I was using network shares. My network share was set up one level further in the folders than my library path.

If you are in the multimedia folder when you click on your NMJ NFS share on your PCH, then you need to remove 'multimedia' from your library path.

To be honest, I don't think I've been much clearer there. Sorry!

Thanks mate, i think i get what you mean! Obviously when I have my jukebox set up, it goes straight to that as the index file is in the root folder! I cant remember which one exactly, but I think its "multimedia", otherwise it would be in "multimedia/Movies"! Actually im 90% sure its in the root folder "multimedia"!

But when i get back home from work, i will check this by first removing the jukebox from the root and then accessing folder through PCH!

But considering this info, of it going straight to the root folder "multimedia", what should be my player path in the library.xml?

Also why does the PCH show the path being volume1/multimedia ?

thanks guys i appreciate all your help! As I had officially run out of any further ideas!
Find all posts by this user
Add Thank You Quote this message in a reply
09-02-2011, 01:23 PM
Post: #9
RE: Videos Not Playing [YAMJ/PCH A210/Macbook/NETWORK_SHARE/SYNOLOGY NAS]
I've edited my post above. I'm pretty sure this is your issue.

PCH C-200, PCH A-110, Onkyo TX-SR875, Toshiba 46XF355D, ReadyNAS NV+ 4TB, ReadyNas NV+ 6TB, Wired cat5e network.
Find all posts by this user
Add Thank You Quote this message in a reply
09-02-2011, 02:05 PM
Post: #10
RE: Videos Not Playing [YAMJ/PCH A210/Macbook/NETWORK_SHARE/SYNOLOGY NAS]
(09-02-2011 01:23 PM)ConciseCarp Wrote:  I've edited my post above. I'm pretty sure this is your issue.

Thanks mate, that does sound quite right! Hopefully it works with this, which will save me a lot of hair tearing out!

One other thing, is there any way to use the index.html file on your pc browser and check if the videos correctly load before testing on the PCH? ie. when i click to play a video on my pc through the jukebox, what should happen? What do you get? Currently, i was just getting a not found error message on white screen and in the URL bar i get the path to that video which was correct, but obviously as the player path is for the player i dont think the video would be accessible through the pc! Is the right?

For example when i click on a video to play i get this returned in the URL bar:

<playerpath>file:///opt/sybhttpd/localhost.drives/NETWORK_SHARE/NMJ NFS/multimedia/Movies/HD Movies/source code.mkv</playerpath>
Find all posts by this user
Add Thank You Quote this message in a reply
09-02-2011, 02:12 PM
Post: #11
RE: Videos Not Playing [YAMJ/PCH A210/Macbook/NETWORK_SHARE/SYNOLOGY NAS]
No problem. I hope it works!

With regards to the PC, I'm not using an HTML skin so can't check, but I don't think I could ever play a movie through the browser on my PC. I'm pretty sure it just used to show the video path. I'm not sure if you can do that. Others may know.

PCH C-200, PCH A-110, Onkyo TX-SR875, Toshiba 46XF355D, ReadyNAS NV+ 4TB, ReadyNas NV+ 6TB, Wired cat5e network.
Find all posts by this user
Add Thank You Quote this message in a reply
09-02-2011, 02:12 PM (This post was last modified: 09-02-2011 02:16 PM by Omertron.)
Post: #12
RE: Videos Not Playing [YAMJ/PCH A210/Macbook/NETWORK_SHARE/SYNOLOGY NAS]
No, there's no way to test the video playback on the PC as the path is for the NMT not PC
Oh, and what Carp said looks good. so try that first before changing your share name.

Make sure you check the XML/HTML of a move to ensure that it's changed (just delete one xml and re-run YAMJ) to make sure that the path has changed and then test it on the PCH so you don't need to rescan the whole jukebox each time

Visit this user's website Find all posts by this user
Add Thank You Quote this message in a reply
09-02-2011, 02:24 PM
Post: #13
RE: Videos Not Playing [YAMJ/PCH A210/Macbook/NETWORK_SHARE/SYNOLOGY NAS]
(09-02-2011 02:12 PM)Omertron Wrote:  No, there's no way to test the video playback on the PC as the path is for the NMT not PC
Oh, and what Carp said looks good. so try that first before changing your share name.

Make sure you check the XML/HTML of a move to ensure that it's changed (just delete one xml and re-run YAMJ) to make sure that the path has changed and then test it on the PCH so you don't need to rescan the whole jukebox each time

ok thanks, at the moment im just deleting whole jukebox each time to prevent any mishaps, its not a problem as my library only contains one movie and one tv set until i get this working, then i will copy over all the others Smile

One final thing, whats the easiest/best way to have multiple jukebox skins in the multimedia folder? At the moment its just creating it on the root, but say if i create a Skins folder and then run terminal to output my YAMJ jukebox to this folder everytime?! This wouldnt still work would it? As it would be overwritten everytime i compile a YAMJ skin!

I just want to manually pick a skin to load each time from my PCH, so that i can change the look anytime i like! Possible or not possible Cool

thanks
Find all posts by this user
Add Thank You Quote this message in a reply
09-02-2011, 02:29 PM (This post was last modified: 09-02-2011 02:33 PM by ConciseCarp.)
Post: #14
RE: Videos Not Playing [YAMJ/PCH A210/Macbook/NETWORK_SHARE/SYNOLOGY NAS]
I think it should be possible, but you would have to have YAMJ create an index file with a different name, like skin.html, skin2.html.

As stated, I am no expert, so this is probably best answered by someone else!

You might want to have a look at iSkin, just so you can see how the skin properties file works, as this creates an index called iSkin.html to get around the very problem you mention.

PCH C-200, PCH A-110, Onkyo TX-SR875, Toshiba 46XF355D, ReadyNAS NV+ 4TB, ReadyNas NV+ 6TB, Wired cat5e network.
Find all posts by this user
Add Thank You Quote this message in a reply
09-02-2011, 03:23 PM
Post: #15
RE: Videos Not Playing [YAMJ/PCH A210/Macbook/NETWORK_SHARE/SYNOLOGY NAS]
(09-02-2011 02:24 PM)killer nads Wrote:  I just want to manually pick a skin to load each time from my PCH, so that i can change the look anytime i like! Possible or not possible Cool
You can't do it automatically yet. You will have to create a new jukebox for each skin.

It is something that I plan to do at some point, but the complexities are beyond a simple change at this point.

Visit this user's website Find all posts by this user
Add Thank You Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Some movies doesn't start under yamj yeri60 0 123 04-18-2014 07:25 PM
Last Post: yeri60
  [YAMJ] Yamj Ubuntu gertvo 5 281 04-18-2014 12:23 PM
Last Post: gertvo
  YAMJ throws repeditive Java seg fault on linux (debian) mithrilG60 11 496 04-16-2014 09:31 AM
Last Post: Omertron
  YAMJ/Eversion: Customer Groups/Categories Adam1v 3 549 04-04-2014 09:30 AM
Last Post: Bazrah
  YAMJ not making any fanart for movies or tv shows simonmullan 15 4,838 04-02-2014 12:19 AM
Last Post: De1Phi4n
  [YAMJ] evZap/eversion Can't create Sets XML file for index Peterkocic 0 605 03-30-2014 11:06 AM
Last Post: Peterkocic
  YAMJ on A200 and A400 davlet 0 317 03-29-2014 07:18 PM
Last Post: davlet
  YAMJ HTML wrong Italian characters in PLOT and name cyberbob 1 431 03-27-2014 09:47 AM
Last Post: Omertron
  YAMJ (eversion+evhell) not seeing data say170 16 854 03-25-2014 10:52 AM
Last Post: Omertron
  Yamj Scan footer and xml question JamesTF 5 655 03-08-2014 02:56 AM
Last Post: jluc2808

Forum Jump: