Firmware: A-410 [01 Apr. 2014] | A-400 [12 Mar. 2014] | C-300 [13 Feb. 2014] | A-300 [24 Feb. 2014] | C-200 [11 July 2013] | A-200/A-210 [11 July 2013] | Popbox V8 [3 Dec 2013]

Just got your NMT | WIKI has the answers | Search the forum | Forum Rules/Policy | Firmware & Official NMT News | Popcornhour manuals



User(s) browsing this thread: 1 Guest(s)
Thread Closed 
Anyone else having issues with HTML crashing the PCH?
07-06-2008, 08:53 AM
Post: #1
Anyone else having issues with HTML crashing the PCH?
OK, let me explain what I am doing...

I am working on yet another media interface. Everyone's previous work is very much appreciated, but I am lazy and need something that will gather and display informatioin on all my media, not just that playable on the PCH.

So, I have written a HTML generator which can handle my media being in physical form for example in one of my DVD juke boxes, or be a DVD rip, or be a HD DVD rip or be on my book case etc... It can retrieve data from IMDb if desired and/or you can manually configure information in a really simple text description file.

The main display is similar to many of the other projects, but the individual details pages give information about where the media is, and if there is a PCH playable version then the options to play them are available. Again, similar to what other folks have done, but with the addition of physical information too.

Now, my HTML works just how I want it on my PC (needs some work on colors etc... but that is another issue), and runs OK for a while on the PCH, including the playing of media, but when I navigate through my details pages the PCH video goes black and then locks up, needing a power cycle to recover.

This only occurs after paging through 20 pages, but it happens reliably at 20 pages.

I have passed my HTML through HTML checkers and there do not appear to be any errors.

Additionally the PCH also does not seem to honor the "style='color:white;background:red'" attributes either. Is this a known limitation, and why people are using css? Do I need to use styles instead?

If anyone could have a look at my HTML and try to repeat my problem I would really appreciate it. Please let me know and I will work out how best to get the HTML to you.

I really need to find the root cause of this before I can even think about releasing the generator since with this problem it is pretty much useless !!

Kind regards,
Steve
Find all posts by this user
07-07-2008, 03:17 PM
Post: #2
 
I had the exact same problems with my llink skin a few times. I am not sure of the exact cause of the issue, but there were a couple of instancces where I could replicate it:

1) Tables inside of divs or divs inside of tables. Almost always caused a crash.
2) Divs overlapping vertically. Didn't crash 100% of time, but by making sure my divs didn't overlap vertically, it eliminate a crash that I saw alot.

The browser is very sensitive. It would be nice to have some better documentation on what tags/layouts it supported.
Find all posts by this user
07-07-2008, 03:26 PM
Post: #3
 
I had this problem when using a empty link with a TVID.
somthing like:
Code:
<a href="" TVID="HOME"></a>
works everytime...

"A common mistake that people make when trying to design something completely foolproof is to underestimate the ingenuity of complete fools."
Douglas Adams
Find all posts by this user
07-07-2008, 06:17 PM
Post: #4
 
I have the same problem with MovieJukebox...after 15-20 pages browsed, my iStar freezes with a blank screen. Since it's not always the same page, my guess is it's not the HTML but rather the caching of artwork by the NMT.
Find all posts by this user
07-07-2008, 09:04 PM
Post: #5
 
scyber Wrote:I had the exact same problems with my llink skin a few times. I am not sure of the exact cause of the issue, but there were a couple of instancces where I could replicate it:

1) Tables inside of divs or divs inside of tables. Almost always caused a crash.
2) Divs overlapping vertically. Didn't crash 100% of time, but by making sure my divs didn't overlap vertically, it eliminate a crash that I saw alot.

The browser is very sensitive. It would be nice to have some better documentation on what tags/layouts it supported.

Interesting!!! I have tables inside divs so I will look closer at this.

BR,
Steve
Find all posts by this user
07-13-2008, 07:58 PM
Post: #6
Re: Anyone else having issues with HTML crashing the PCH?
garfieldboy Wrote:OK, let me explain what I am doing...

I am working on yet another media interface. Everyone's previous work is very much appreciated, but I am lazy and need something that will gather and display informatioin on all my media, not just that playable on the PCH.

So, I have written a HTML generator which can handle my media being in physical form for example in one of my DVD juke boxes, or be a DVD rip, or be a HD DVD rip or be on my book case etc... It can retrieve data from IMDb if desired and/or you can manually configure information in a really simple text description file.

The main display is similar to many of the other projects, but the individual details pages give information about where the media is, and if there is a PCH playable version then the options to play them are available. Again, similar to what other folks have done, but with the addition of physical information too.

Now, my HTML works just how I want it on my PC (needs some work on colors etc... but that is another issue), and runs OK for a while on the PCH, including the playing of media, but when I navigate through my details pages the PCH video goes black and then locks up, needing a power cycle to recover.

This only occurs after paging through 20 pages, but it happens reliably at 20 pages.

I have passed my HTML through HTML checkers and there do not appear to be any errors.

Additionally the PCH also does not seem to honor the "style='color:white;background:red'" attributes either. Is this a known limitation, and why people are using css? Do I need to use styles instead?

If anyone could have a look at my HTML and try to repeat my problem I would really appreciate it. Please let me know and I will work out how best to get the HTML to you.

I really need to find the root cause of this before I can even think about releasing the generator since with this problem it is pretty much useless !!

Kind regards,
Steve

I have seen sth similiar with LightTPD. After browsing > 20-30 pages, PCH crashed, and I have to power-on reset to bring it back. The HTML page is OK, because I can browse it directly, if I do not browse too many pages earlier. I know this is not LightTPD issue, because I can browse several times on my PC.
Find all posts by this user
08-07-2008, 12:23 AM (This post was last modified: 08-07-2008 12:23 AM by trunkmonkey.)
Post: #7
RE: Anyone else having issues with HTML crashing the PCH?
This sounds very similar, if not the same, as what I am experiencing with my dynamically generated html, as described here.

I think that kpziegler is on the money... it appears to be a problem with hitting a limitation of the image cache.

It would be really nice if they could implement some sort of least-recently-used eviction policy rather than let the box commit seppuku when it runs out of space in the cache confused
Find all posts by this user
08-07-2008, 02:41 AM (This post was last modified: 08-07-2008 02:43 AM by journey4712.)
Post: #8
RE: Anyone else having issues with HTML crashing the PCH?
There are many problems with the web browser, not just the images Smile For instance today i was playing with some css, I couldn't get my divs to go in the right place so i tried to absolutly position them, and i crash gaya Smile Problably what was mentioned earlier with the divs overlaping, will have to try some other things. no power cycle needed though just telnet into your pch and run the gaya program. I couldn't imagine waiting for this thing to reboot everytime i've crashed gaya today.

journey
sample gaya output
Code:
apply_tvmode  >> 11
[HDMI] ========================== creating pDH ==========================
[HDMI] Detected part at I2C device address 0x72: vendor 0x0001, device 9253, rev.0x02 (Silicon Image)
[HDMI] Using the part: SiI9030 (4), Vendor ID is 0x0001 / 0x9253
[HDMI]    ***   HotPlug changed, is now ON
[HDMI]    ***   Rx changed, is now ON
[HDMI]    ***   Clock changed, is now STABLE
parse_display_cmdline.c: Application did not specify HDCP SRM, providing empty SRM!
[HDMI] DHCancelHDCP()

  HH  HH  HHHHH   HH   HH  HHHH      HHHH   HH   HH
  HH  HH  HH  HH  HHH HHH   HH      HH  HH  HHH  HH
  HHHHHH  HH  HH  HH H HH   HH      HH  HH  HH H HH
  HH  HH  HH  HH  HH   HH   HH      HH  HH  HH  HHH
  HH  HH  HHHHH   HH   HH  HHHH      HHHH   HH   HH

[HDMI] DHGetVideoModeFromEDID(): Looking for 16:9 mode in YCbCr
Monitor is HDMI
[HDMI] DHSetHDMIMode(TRUE)
[HDMI] Sending blank AudioInfoFrames
[HDMI] Sending null packet
[HDMI] DHUpdateVideoPixelClock(148500000)
HDMI Colorspace is now: RGB limited range
Monitor is HDMI
[HDMI]    ***   Clock changed, is now STABLE
apply_tvmode  >> 11
[HDMI] DHCancelHDCP()

  HH  HH  HHHHH   HH   HH  HHHH      HHHH   HH   HH
  HH  HH  HH  HH  HHH HHH   HH      HH  HH  HHH  HH
  HHHHHH  HH  HH  HH H HH   HH      HH  HH  HH H HH
  HH  HH  HH  HH  HH   HH   HH      HH  HH  HH  HHH
  HH  HH  HHHHH   HH   HH  HHHH      HHHH   HH   HH

[HDMI] DHGetVideoModeFromEDID(): Looking for 16:9 mode in YCbCr
Monitor is HDMI
[HDMI] DHSetHDMIMode(TRUE)
[HDMI] DHUpdateVideoPixelClock(148500000)
HDMI Colorspace is now: RGB limited range
Monitor is HDMI
[HDMI]    ***   Clock changed, is now STABLE
start parse
start parse
start parse
start parse
start parse
[1] + Killed                     gaya
/ # gaya
apply_tvmode  >> 11
[HDMI] ========================== creating pDH ==========================
[HDMI] Detected part at I2C device address 0x72: vendor 0x0001, device 9253, rev.0x02 (Silicon Image)
[HDMI] Using the part: SiI9030 (4), Vendor ID is 0x0001 / 0x9253
[HDMI]    ***   HotPlug changed, is now ON
[HDMI]    ***   Rx changed, is now ON
[HDMI]    ***   Clock changed, is now STABLE
parse_display_cmdline.c: Application did not specify HDCP SRM, providing empty SRM!
[HDMI] DHCancelHDCP()

  HH  HH  HHHHH   HH   HH  HHHH      HHHH   HH   HH
  HH  HH  HH  HH  HHH HHH   HH      HH  HH  HHH  HH
  HHHHHH  HH  HH  HH H HH   HH      HH  HH  HH H HH
  HH  HH  HH  HH  HH   HH   HH      HH  HH  HH  HHH
  HH  HH  HHHHH   HH   HH  HHHH      HHHH   HH   HH

[HDMI] DHGetVideoModeFromEDID(): Looking for 16:9 mode in YCbCr
Monitor is HDMI
[HDMI] DHSetHDMIMode(TRUE)
[HDMI] Sending blank AudioInfoFrames
[HDMI] Sending null packet
[HDMI] DHUpdateVideoPixelClock(148500000)
HDMI Colorspace is now: RGB limited range
Monitor is HDMI
[HDMI]    ***   Clock changed, is now STABLE
apply_tvmode  >> 11
[HDMI] DHCancelHDCP()

  HH  HH  HHHHH   HH   HH  HHHH      HHHH   HH   HH
  HH  HH  HH  HH  HHH HHH   HH      HH  HH  HHH  HH
  HHHHHH  HH  HH  HH H HH   HH      HH  HH  HH H HH
  HH  HH  HH  HH  HH   HH   HH      HH  HH  HH  HHH
  HH  HH  HHHHH   HH   HH  HHHH      HHHH   HH   HH

[HDMI] DHGetVideoModeFromEDID(): Looking for 16:9 mode in YCbCr
Monitor is HDMI
[HDMI] DHSetHDMIMode(TRUE)
[HDMI] DHUpdateVideoPixelClock(148500000)
HDMI Colorspace is now: RGB limited range
Monitor is HDMI
[HDMI]    ***   Clock changed, is now STABLE
start parse
start parse
start parse
start parse
start parse
start parse
start parse
Segmentation fault
Find all posts by this user
08-14-2008, 04:29 PM
Post: #9
RE: Anyone else having issues with HTML crashing the PCH?
(08-07-2008 02:41 AM)journey4712 Wrote:  There are many problems with the web browser, not just the images Smile For instance today i was playing with some css, I couldn't get my divs to go in the right place so i tried to absolutly position them, and i crash gaya Smile Problably what was mentioned earlier with the divs overlaping, will have to try some other things. no power cycle needed though just telnet into your pch and run the gaya program. I couldn't imagine waiting for this thing to reboot everytime i've crashed gaya today.

[/code]

I also experience this problem quite frequently while using YAMJ. It started happening so oftern (once my movie collection got bigger and bigger) that I had to quit using YAMJ, which REALLY sucks, becase I loved it!

If anyone knows of anyting I can do to avoid this issue, PLEASE let me know. Even a work-around would help (someway to "clear" the cache every so often without resetting the PCH).

Anyone know if this cache issue is being worked on for the next firmware release?

Thank you!
Find all posts by this user
11-14-2008, 05:13 AM
Post: #10
RE: Anyone else having issues with HTML crashing the PCH?
Quote:Anyone know if this cache issue is being worked on for the next firmware release?

Thank you!

well, how about the next next firmware? any chance this can be addressed for non HDD units?
(yup, having the same problem...Sad )

peace ~ jdc
Find all posts by this user
11-14-2008, 09:56 AM (This post was last modified: 11-14-2008 09:56 AM by louislambeau.)
Post: #11
RE: Anyone else having issues with HTML crashing the PCH?
Hi,

i've also some crash experience with the pch-browser and frames tag.

Anyone else ?
Find all posts by this user
11-14-2008, 01:59 PM
Post: #12
RE: Anyone else having issues with HTML crashing the PCH?
the popcornhour doesn't support frames at all...you must use tables.
Find all posts by this user
11-14-2008, 02:19 PM
Post: #13
RE: Anyone else having issues with HTML crashing the PCH?
(11-14-2008 01:59 PM)excal Wrote:  the popcornhour doesn't support frames at all...you must use tables.

Ok... It doesn't support frames... But crashing when a frame is present : isn't a little bit excessive ?
Find all posts by this user
11-14-2008, 05:01 PM
Post: #14
RE: Anyone else having issues with HTML crashing the PCH?
you'll find that if you try anything the nmt doesn't use or like...it'll freak out and reboot.


such as placing tables with absolute positioning Smile
Find all posts by this user
Thread Closed 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  MyLil Movie Jukebox no index html file? whyioughta 2 2,319 12-07-2010 03:08 AM
Last Post: whyioughta
  HTML problem: ol + img nexushoratio 7 4,896 06-02-2010 03:08 PM
Last Post: excal
  NMT HTML questions Ahri 3 3,202 12-23-2009 11:21 AM
Last Post: DefBref
  HTML Gaya Form Controls vs CSS lordy 0 1,811 11-22-2009 09:25 PM
Last Post: lordy
  Skinmaker gurus: Gaya / html aligning content from bottom of screen upwards... lordy 4 2,166 10-16-2009 04:07 AM
Last Post: lordy
  Automounting from external html (+ISOs) - no software mod required. ?? (eg YAMJ skin) lordy 11 3,628 10-14-2009 10:31 PM
Last Post: lordy
  html question: input type=text deusued 0 972 09-05-2009 04:30 AM
Last Post: deusued
  Network Issues palanisr 7 2,043 08-21-2009 04:24 PM
Last Post: palanisr
  Image Rendering Problem - PCH HTML Browser shaggyjb 29 10,300 08-01-2009 12:17 PM
Last Post: philofred
  preview the html part from a cgi file ? meowmoo 1 1,419 06-10-2009 12:53 AM
Last Post: mhut

Forum Jump: