Firmware: A-410 [01 Apr. 2014] | A-400 [12 Mar. 2014] | C-300 [13 Feb. 2014] | A-300 [24 Feb. 2014] | C-200 [11 July 2013] | A-200/A-210 [11 July 2013] | Popbox V8 [3 Dec 2013]

Just got your NMT | WIKI has the answers | Search the forum | Forum Rules/Policy | Firmware & Official NMT News | Popcornhour manuals



User(s) browsing this thread: 1 Guest(s)
Post Reply 
Failure to install NMT application
01-07-2012, 10:14 AM (This post was last modified: 01-09-2012 10:50 PM by zofer.)
Post: #1
Failure to install NMT application
Hi,

I have A200 for about about a year now, with internal HDD. For some unknown reason, the samba and ftp and other NMT applications have stopped working. To fix this, I have tried to re-install NMT applications using the setup wizard. This did not help. I tried to update to latest firmware and re-install NMT apps using setup wizard, with no luck. Note that all the time the HDD is accessible and working great. I also have custom telnetd working so I can connect to my A200. I also tried re-installing the apps on USB stick. It says installation is completed successfully, but no file is written to the USB stick. I have also tried to remove all unused custom applications, but nothing seems to make any difference.

Whenever I run the NMT Apps setup wizard, on existing media (HDD or DOK), setup completes in a spplit of a second, but does nothing, and there is no NMT apps.

I have also tried to follow the procedure for manuall installation but that does not seem to detect the apps.nmt file.

Help is greatly appriciated.

zofer

[EDIT]

I have found this thread: http://www.networkedmediatank.com/showth...?tid=50384

I than examined my disk again and all mounted partitions.
fdisk -l /dev/sda:
/dev/sda1 63 1975994 987966 83 Linux
/dev/sda2 1975995 2988089 506047+ 82 Linux swap
/dev/sda3 2988090 6907949 1959930 83 Linux
/dev/sda4 6907950 976768064 484930057+ 83 Linux

From a reverse engineering point of view, the a200 create 4 partitions:
1. 2GB partitions for apps - ext3
2. 1GB swap
3. 2GB partition for bdj (what is this @#$% anyway?) ext3
4. rest of the disk for Photo,Video,Music - ext3

mount:
rootfs on / type rootfs (rw)
proc on /proc type proc (rw)
usbfs on /proc/bus/usb type usbfs (rw)
sysfs on /sys type sysfs (rw)
tmpfs on /tmp type tmpfs (rw)
/dev/sigmblocke on /opt/syb type squashfs (ro)
/dev/sigmblockm on /opt/syb/local type romfs (ro)
/dev/sigmblockn on /opt/syb/usr type ext3 (rw,noatime,nodiratime,data=ordered)
/dev/sigmblocko on /etc/stagecraft-data type ext3 (rw,noatime,nodiratime,data=ordered)
/dev/sigmblockf on /opt/syb/share type squashfs (ro)
/dev/nblock8 on /mnt type ext3 (rw,noatime,data=journal)
/dev/sda3 on /opt/sybhttpd/localhost.drives/SATA_DISK type ext3 (rw,noatime,nodiratime,data=ordered)
/dev/sda4 on /opt/sybhttpd/localhost.drives/SATA_DISK_A4 type ext3 (rw,noatime,nodiratime,data=ordered)

For some odd reason, my first partition fails to mount, or the a200 have hard time using it. Maybe it is trashed. This is probably why setup wizard does nothing and reboots.

mkdir /nmt
mount /dev/sda1 /nmt
mount: mounting /dev/sda1 on /nmt failed: Invalid argument

Why? who knows...

I figured that if HDD is pre-formatted to NTFS, it does all that as files instead of partitions.

This means in my case, that I need to back-up everything and reformat my disk.

The temporary workaround I am using as follows:
1. Physically disconnect the HDD
2. Put USB DOK
3. Fresh install nmt apps on USB
4. Reconnect HDD
5. Use apps from USB and data from HDD

I hope it will help any one.

zofer
Find all posts by this user
Add Thank You Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Install NMT Apps to USB Stick DzigiBau 3 506 02-28-2014 08:07 PM
Last Post: dvonk
  NMT application Fresh setup problem Macarale 0 293 01-27-2014 08:27 PM
Last Post: Macarale
  New Motherboard Install Issues bishftl 4 488 11-05-2013 11:45 AM
Last Post: Willem53
  2TB Internal HDD Install Question zeek 1 984 04-20-2013 01:29 PM
Last Post: shamoo
  C-200 startup failure moquilok 3 994 04-16-2013 02:44 AM
Last Post: moquilok
  Install HDD Western Digital sar100 0 596 02-15-2013 06:27 PM
Last Post: sar100
  Total power failure.. crazy A200 issues! Gangel 4 871 12-27-2012 04:47 AM
Last Post: Gangel
  Can I install a 3tb NTFS internal drive in an A210 glen8 12 7,923 09-24-2012 09:43 AM
Last Post: sturle
  Help.....NMT Application Setup page gone missing? Can't connect from PC... Rated-R-Ron 6 1,534 09-19-2012 06:46 AM
Last Post: Rated-R-Ron
  C-200 no HDMI Signal after RSU Failure - fixed by Mainboard Reset mic23 5 1,451 09-08-2012 06:48 PM
Last Post: jluc2808

Forum Jump: